aboutsummaryrefslogtreecommitdiffstats
path: root/community/plasma-desktop
diff options
context:
space:
mode:
authorBart Ribbers <bribbers@disroot.org>2019-10-18 16:13:36 +0200
committerLeo <thinkabit.ukim@gmail.com>2019-10-20 12:24:41 -0300
commitb3553abc60cd45495f8a252a5a06ca25c6749952 (patch)
tree89dc4e90e78d313a485ccb0fd7264c132d9d4381 /community/plasma-desktop
parent9a177212eb91a159b575312d0824a790ad551adf (diff)
downloadaports-b3553abc60cd45495f8a252a5a06ca25c6749952.tar.bz2
aports-b3553abc60cd45495f8a252a5a06ca25c6749952.tar.xz
community/plasma: upgrade to 5.17.0
Diffstat (limited to 'community/plasma-desktop')
-rw-r--r--community/plasma-desktop/APKBUILD21
1 files changed, 15 insertions, 6 deletions
diff --git a/community/plasma-desktop/APKBUILD b/community/plasma-desktop/APKBUILD
index f42055cd30..ab773f0b75 100644
--- a/community/plasma-desktop/APKBUILD
+++ b/community/plasma-desktop/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=plasma-desktop
-pkgver=5.16.5
+pkgver=5.17.0
pkgrel=0
pkgdesc="KDE Plasma Desktop"
arch="all !ppc64le !s390x" # Limited by plasma-workspace -> libksysguard -> qt5-qtwebengine
@@ -39,7 +39,7 @@ depends_dev="
fontconfig-dev
eudev-dev
xf86-input-libinput-dev
- xf86-input-evdev-dev
+ xf86-input-evdev-dev
xf86-input-synaptics-dev
libxkbfile-dev
libxcursor-dev
@@ -47,12 +47,19 @@ depends_dev="
"
makedepends="$depends_dev extra-cmake-modules kdoctools-dev"
checkdepends="xvfb-run iso-codes"
-source="https://download.kde.org/stable/plasma/$pkgver/$pkgname-$pkgver.tar.xz"
+source="https://download.kde.org/stable/plasma/$pkgver/plasma-desktop-$pkgver.tar.xz"
subpackages="$pkgname-dev $pkgname-doc $pkgname-lang knetattach"
options="!check" # Requires running dbus
+prepare() {
+ default_prepare
+
+ mkdir "$builddir"/build
+}
+
build() {
- cmake \
+ cd "$builddir"/build
+ cmake "$builddir" \
-DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib
@@ -60,10 +67,12 @@ build() {
}
check() {
+ cd "$builddir"/build
CTEST_OUTPUT_ON_FAILURE=TRUE xvfb-run ctest
}
package() {
+ cd "$builddir"/build
DESTDIR="$pkgdir" make install
rm "$pkgdir"/usr/bin/knetattach
@@ -74,7 +83,7 @@ knetattach() {
pkgdesc="Wizard which makes it easier to integrate network resources with the Plasma Desktop"
depends="kdelibs4support"
- cd "$builddir"/knetattach
+ cd "$builddir"/build/knetattach
DESTDIR="$subpkgdir" make install
}
-sha512sums="7a4678928ccfd511746ceea53a4c31d15dfddafdeef3d9b169088a186ea1f5787eb3589ad5dbd3892b4669a7a833311da41795562fc94a58ac7aa2f02a741192 plasma-desktop-5.16.5.tar.xz"
+sha512sums="159c9776adefe699f2ae1abea7d72d123231e9f1226bd924c5b3b01efe5724fe4caeee53010e7fce08f680e0ea1c50654294f11253ecee0ac43d37614e30d801 plasma-desktop-5.17.0.tar.xz"