aboutsummaryrefslogtreecommitdiffstats
path: root/community/plasma-framework
diff options
context:
space:
mode:
authorBart Ribbers <bribbers@disroot.org>2019-10-14 19:46:37 +0200
committerLeo <thinkabit.ukim@gmail.com>2019-10-17 12:13:50 -0300
commit49afd00440e7a1725cb4701a2ff879e994a55389 (patch)
tree915f5c810b7027a5a99e9ed935ab50f9d8dde87e /community/plasma-framework
parente58bd7992d0d7b657f02561eb4c255bdfe6751d6 (diff)
downloadaports-49afd00440e7a1725cb4701a2ff879e994a55389.tar.bz2
aports-49afd00440e7a1725cb4701a2ff879e994a55389.tar.xz
community/kde-frameworks: upgrade to 5.63.0
Diffstat (limited to 'community/plasma-framework')
-rw-r--r--community/plasma-framework/APKBUILD15
1 files changed, 12 insertions, 3 deletions
diff --git a/community/plasma-framework/APKBUILD b/community/plasma-framework/APKBUILD
index ac6147f4a4..b3b2c0a132 100644
--- a/community/plasma-framework/APKBUILD
+++ b/community/plasma-framework/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=plasma-framework
-pkgver=5.62.0
+pkgver=5.63.0
pkgrel=0
pkgdesc="Plasma library and runtime components based upon KF5 and Qt5"
arch="all"
@@ -14,8 +14,15 @@ source="https://download.kde.org/stable/frameworks/${pkgver%.*}/plasma-framework
subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
options="!check" # 8 out of 13 tests fail
+prepare() {
+ default_prepare
+
+ mkdir "$builddir"/build
+}
+
build() {
- cmake \
+ cd "$builddir"/build
+ cmake "$builddir" \
-DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib \
@@ -24,10 +31,12 @@ build() {
}
check() {
+ cd "$builddir"/build
CTEST_OUTPUT_ON_FAILURE=TRUE xvfb-run ctest
}
package() {
+ cd "$builddir"/build
DESTDIR="$pkgdir" make install
}
-sha512sums="66980e3935e28da1ae8f46047d959a050a5551ca3aa17f7f7b4a42ab9cfc01231594072951b1fbc68fe55e40f938cfe82fb9a0a9202bc9b6eb753e22d74228ec plasma-framework-5.62.0.tar.xz"
+sha512sums="1ef88a159c803aaa791cca941c365f26ce05cfa0328e0dfabbec429a18b02781dfe6f82d03cd29a1d16d2b720c710fec0be11bfc790a99205443f7289dff76ec plasma-framework-5.63.0.tar.xz"