aboutsummaryrefslogtreecommitdiffstats
path: root/community/plasma-framework
diff options
context:
space:
mode:
authorBart Ribbers <bribbers@disroot.org>2019-07-14 00:55:42 +0200
committerLeo <thinkabit.ukim@gmail.com>2019-07-13 22:20:39 -0300
commitc702f2a812cfbc5c0c1a68b6f120cf332f788f1f (patch)
tree800e1687809b5e688995a9948d19af9e577a167d /community/plasma-framework
parent8d48f29796e55f6906ecb8cb8ef27e1b4dc3b820 (diff)
downloadaports-c702f2a812cfbc5c0c1a68b6f120cf332f788f1f.tar.bz2
aports-c702f2a812cfbc5c0c1a68b6f120cf332f788f1f.tar.xz
community/kde-frameworks: move from testing
Diffstat (limited to 'community/plasma-framework')
-rw-r--r--community/plasma-framework/APKBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/community/plasma-framework/APKBUILD b/community/plasma-framework/APKBUILD
new file mode 100644
index 0000000000..8955109b17
--- /dev/null
+++ b/community/plasma-framework/APKBUILD
@@ -0,0 +1,33 @@
+# Contributor: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: Bart Ribbers <bribbers@disroot.org>
+pkgname=plasma-framework
+pkgver=5.60.0
+pkgrel=0
+pkgdesc="Plasma library and runtime components based upon KF5 and Qt5"
+arch="all"
+url="https://community.kde.org/Frameworks"
+license="LGPL-2.1-or-later AND GPL-2.0-or-later"
+depends_dev="qt5-qtbase-dev qt5-qtdeclarative-dev qt5-qtquickcontrols2-dev kactivities-dev karchive-dev kconfig-dev kconfigwidgets-dev kcoreaddons-dev kdbusaddons-dev kdeclarative-dev kglobalaccel-dev kguiaddons-dev ki18n-dev kiconthemes-dev kio-dev kservice-dev kwindowsystem-dev kxmlgui-dev knotifications-dev kpackage-dev kirigami2-dev kwayland-dev"
+makedepends="$depends_dev extra-cmake-modules qt5-qttools-dev doxygen kdoctools-dev"
+checkdepends="xvfb-run mesa-dri-swrast hicolor-icon-theme"
+source="https://download.kde.org/stable/frameworks/${pkgver%.*}/$pkgname-$pkgver.tar.xz"
+subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
+options="!check" # 8 out of 13 tests fail
+
+build() {
+ cmake \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=lib \
+ -DBUILD_QCH=ON
+ make
+}
+
+check() {
+ CTEST_OUTPUT_ON_FAILURE=TRUE xvfb-run ctest
+}
+
+package() {
+ DESTDIR="$pkgdir" make install
+}
+sha512sums="1dbffbc9ed15470a8bb8b78e4f6c222a0acf163ba8e56ce33593bf732dcd0289e531d4c05e1bd313e808266c2bd53a629cb37152e65b254a3de74920d9e57f12 plasma-framework-5.60.0.tar.xz"