aboutsummaryrefslogtreecommitdiffstats
path: root/community/plymouth/APKBUILD
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2017-01-31 11:26:37 +0200
committerTimo Teräs <timo.teras@iki.fi>2017-01-31 11:26:37 +0200
commit88722fca6c4d08fa5d294c9d0981d5f36c511528 (patch)
treea6a77ed950dc63f2fce88d8af7d3f2249b324c42 /community/plymouth/APKBUILD
parentcf0a5d75f1fd50eb08833397df5bb889938faa9f (diff)
downloadaports-88722fca6c4d08fa5d294c9d0981d5f36c511528.tar.bz2
aports-88722fca6c4d08fa5d294c9d0981d5f36c511528.tar.xz
community/plymouth: moved from testing
Diffstat (limited to 'community/plymouth/APKBUILD')
-rw-r--r--community/plymouth/APKBUILD68
1 files changed, 68 insertions, 0 deletions
diff --git a/community/plymouth/APKBUILD b/community/plymouth/APKBUILD
new file mode 100644
index 0000000000..11ed3c98a3
--- /dev/null
+++ b/community/plymouth/APKBUILD
@@ -0,0 +1,68 @@
+# Contributor: William Pitcock <nenolod@dereferenced.org>
+# Maintainer: Timo Teräs <timo.teras@iki.fi>
+pkgname=plymouth
+pkgver=0.9.2
+pkgrel=1
+pkgdesc="graphical bootsplash on linux"
+url="http://www.freedesktop.org/wiki/Software/Plymouth"
+arch="all"
+license="GPL"
+depends=""
+depends_dev="pango-dev
+ gtk+3.0-dev
+ libpng-dev
+ libdrm-dev"
+makedepends="$depends_dev docbook-xsl autoconf automake libtool"
+install=""
+subpackages="$pkgname-dev $pkgname-doc $pkgname-themes $pkgname-x11:_render $pkgname-drm:_render"
+source="http://www.freedesktop.org/software/plymouth/releases/plymouth-$pkgver.tar.bz2
+ plymouth-rpmatch.patch
+ plymouth-git-master-20170123.patch
+ "
+
+builddir="$srcdir"/plymouth-$pkgver
+
+prepare() {
+ default_prepare || return 1
+ autoreconf -f -i -s
+}
+
+build() {
+ cd "$builddir"
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --localstatedir=/var \
+ --with-system-root-install \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install || return 1
+
+ rm -f "$pkgdir"/usr/lib/plymouth/*.la
+}
+
+themes() {
+ mkdir -p "$subpkgdir"/usr/share/plymouth/
+ mv "$pkgdir"/usr/share/plymouth/themes/ "$subpkgdir"/usr/share/plymouth/
+}
+
+_render() {
+ local _name=${subpkgname#${pkgname}-}
+ mkdir -p "$subpkgdir"/usr/lib/plymouth/renderers
+ mv "$pkgdir"/usr/lib/plymouth/renderers/$_name.so "$subpkgdir"/usr/lib/plymouth/renderers
+}
+
+md5sums="ff420994deb7ea203df678df92e7ab7d plymouth-0.9.2.tar.bz2
+7d342aa2f011833647f1c696007b190c plymouth-rpmatch.patch
+d3451ffd12270bdbdaf563c64580addc plymouth-git-master-20170123.patch"
+sha256sums="2f0ce82042cf9c7eadd2517a1f74c8a85fa8699781d9f294a06eade29fbed57f plymouth-0.9.2.tar.bz2
+2281bffcd64de8c2e675656d21b26b0a74fa997af52e941fe6f356d8d4362e37 plymouth-rpmatch.patch
+cdbaa71a099bbb75d669db0c581770611ebd82dc5506ae7934cb4b64afdbd7bb plymouth-git-master-20170123.patch"
+sha512sums="89356eb8326504fbf3155de262ce15de0847f0a0e6d157d873cf1dea9af464a6cb9e11d7143ee9a595b217a2487060b5835eba5ac142c3cd6d66689deb272e60 plymouth-0.9.2.tar.bz2
+ec1c32ddf7ee418ef1b5d173040db464193d9bca3fd85d5c3a8d2ee13ba1218947f7c9f39c403d3ccced70be28b2c7328e82dc8f967e9bdeea1651dee4be2dc7 plymouth-rpmatch.patch
+6545c29190b9cf04df0284a73c26ec7d14fddf2c4d7a8f3dff5242b49fafda24ee2aeab54b44b19deb9228707816b6b3779ea8bec7b742020cb1f7e2ca64b509 plymouth-git-master-20170123.patch"