aboutsummaryrefslogtreecommitdiffstats
path: root/community/polkit-qt-1/APKBUILD
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-07-13 22:38:07 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-07-13 22:38:07 -0300
commitae0d4bce74ebf5c86132811e185fc5644870f330 (patch)
tree0f498a0cba54e031129d5cd0b5ab7b897a38fe3f /community/polkit-qt-1/APKBUILD
parent6f220467bdd686681ec8cbb1c1eb4f2e2adce34f (diff)
downloadaports-ae0d4bce74ebf5c86132811e185fc5644870f330.tar.bz2
aports-ae0d4bce74ebf5c86132811e185fc5644870f330.tar.xz
community/polkit-qt-1: move from testing
Diffstat (limited to 'community/polkit-qt-1/APKBUILD')
-rw-r--r--community/polkit-qt-1/APKBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/community/polkit-qt-1/APKBUILD b/community/polkit-qt-1/APKBUILD
new file mode 100644
index 0000000000..ce8b0d1026
--- /dev/null
+++ b/community/polkit-qt-1/APKBUILD
@@ -0,0 +1,30 @@
+# Contributor: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: Bart Ribbers <bribbers@disroot.org>
+pkgname=polkit-qt-1
+pkgver=0.112.0
+pkgrel=1
+pkgdesc="Qt wrapper around polkit-1 client libraries"
+arch="all"
+url="https://www.kde.org"
+license="LGPL-2.1-only"
+depends_dev="polkit-elogind-dev"
+makedepends="$depends_dev cmake qt5-qtbase-dev"
+source="https://download.kde.org/stable/apps/KDE4.x/admin/$pkgname-$pkgver.tar.bz2"
+subpackages="$pkgname-dev"
+
+build() {
+ cmake \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=lib
+ make
+}
+
+check() {
+ CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+}
+
+package() {
+ DESTDIR="$pkgdir" make install
+}
+sha512sums="4cb17389b54a09c53052f6d72aa5cbfe09ccb19f7fd4edf8b43ccd4751f5e88609c5f89777f4af92167d32eb2ce1e78537cea7bcfb60a90072d1fe02d6a59b50 polkit-qt-1-0.112.0.tar.bz2"