aboutsummaryrefslogtreecommitdiffstats
path: root/community/potrace
diff options
context:
space:
mode:
authorFrancesco Colista <fcolista@alpinelinux.org>2016-08-24 16:07:30 +0000
committerFrancesco Colista <fcolista@alpinelinux.org>2016-08-24 16:07:30 +0000
commitda39f565fd9d46e3cc44db1e9a920bf752a34bb0 (patch)
treef4bef4f58d4f74a91a7774e42ef0291de3d99aaa /community/potrace
parent48e4e4128c7a60bb68d6d390338831ecc293c28c (diff)
downloadaports-da39f565fd9d46e3cc44db1e9a920bf752a34bb0.tar.bz2
aports-da39f565fd9d46e3cc44db1e9a920bf752a34bb0.tar.xz
community/potrace: moved from testing
Diffstat (limited to 'community/potrace')
-rw-r--r--community/potrace/APKBUILD38
1 files changed, 38 insertions, 0 deletions
diff --git a/community/potrace/APKBUILD b/community/potrace/APKBUILD
new file mode 100644
index 0000000000..0f67bb6bd1
--- /dev/null
+++ b/community/potrace/APKBUILD
@@ -0,0 +1,38 @@
+# Contributor: Francesco Colista <fcolista@alpinelinux.org>
+# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
+pkgname=potrace
+pkgver=1.13
+pkgrel=0
+pkgdesc="Utility for tracing a bitmaps"
+url="http://potrace.sourceforge.net/"
+arch="all"
+license="GPL"
+depends=""
+depends_dev="zlib-dev"
+makedepends="$depends_dev"
+install=""
+subpackages="$pkgname-dev $pkgname-doc"
+source="http://potrace.sourceforge.net/download/${pkgver}/${pkgname}-${pkgver}.tar.gz"
+
+builddir="${srcdir}"/${pkgname}-${pkgver}
+
+build() {
+ cd "$builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --mandir=/usr/share/man \
+ --with-libpotrace \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="${pkgdir}" install
+}
+
+md5sums="f26888fc2fbfa96fa79ce07fdcf4bb70 potrace-1.13.tar.gz"
+sha256sums="6252438b6b6644b9b6298056b4c5de3690a1d4e862b66889abe21eecdf16b784 potrace-1.13.tar.gz"
+sha512sums="d7b1e72bee388aa309a5fbf3944b9409d912f2ed8a089a44dfca597b55d88bdf08778d40fc487e6689a873631c24cd393894ff353442dc778dfd0d3068121484 potrace-1.13.tar.gz"