aboutsummaryrefslogtreecommitdiffstats
path: root/community/prometheus
diff options
context:
space:
mode:
authornixfloyd <nixfloyd@gmail.com>2020-01-02 04:52:07 +0000
committerLeo <thinkabit.ukim@gmail.com>2020-01-02 10:28:53 +0100
commit1697b65e5f99109e3fc987a81e7a988f0e432187 (patch)
tree0ae856006d41990725b0dc622a323ec6f1eb5c60 /community/prometheus
parent78a5dce1b73c4cf263313b34893960e119688e8f (diff)
downloadaports-1697b65e5f99109e3fc987a81e7a988f0e432187.tar.bz2
aports-1697b65e5f99109e3fc987a81e7a988f0e432187.tar.xz
community/prometheus: move build steps back to build()
Diffstat (limited to 'community/prometheus')
-rw-r--r--community/prometheus/APKBUILD5
1 files changed, 1 insertions, 4 deletions
diff --git a/community/prometheus/APKBUILD b/community/prometheus/APKBUILD
index 76eeada46e..8a83fe83aa 100644
--- a/community/prometheus/APKBUILD
+++ b/community/prometheus/APKBUILD
@@ -16,8 +16,7 @@ source="
subpackages="$pkgname-openrc"
options="!check" # Broken by integrations we don't care about
-prepare() {
- default_prepare
+build() {
cd web/ui/react-app
yarn --frozen-lockfile
yarn lint
@@ -27,9 +26,7 @@ prepare() {
go generate -x -v
cd ../../
gofmt -w ./web/ui
-}
-build() {
go build \
-trimpath \
-mod=vendor \