aboutsummaryrefslogtreecommitdiffstats
path: root/community/prosody
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-05-24 23:30:29 -0300
committerTBK <tbk@jjtc.eu>2019-05-25 17:01:29 +0200
commit8ed4689a3214b15f6c6529015163cc45933d19a2 (patch)
tree1ae32d05ab75d00f2e7a6aa1a810590cd4d66351 /community/prosody
parent70729c17cc2ac868cf50efbffab7ed8684d1bc59 (diff)
downloadaports-8ed4689a3214b15f6c6529015163cc45933d19a2.tar.bz2
aports-8ed4689a3214b15f6c6529015163cc45933d19a2.tar.xz
community/prosody: modernize
Closes: GH-8045
Diffstat (limited to 'community/prosody')
-rw-r--r--community/prosody/APKBUILD7
1 files changed, 1 insertions, 6 deletions
diff --git a/community/prosody/APKBUILD b/community/prosody/APKBUILD
index fd3148845e..df6fea0871 100644
--- a/community/prosody/APKBUILD
+++ b/community/prosody/APKBUILD
@@ -9,7 +9,7 @@ url="http://prosody.im/"
arch="all"
license="MIT"
depends="lua${_luaver}-socket lua${_luaver}-expat lua${_luaver}-filesystem
- lua${_luaver}-sec lua${_luaver} lua${_luaver}-busted lua${_luaver}"
+ lua${_luaver}-sec lua${_luaver} lua${_luaver}-busted"
makedepends="linux-headers lua${_luaver}-dev libidn-dev openssl-dev"
checkdepends="lua-busted"
install="prosody.pre-install"
@@ -21,10 +21,7 @@ source="https://prosody.im/downloads/source/$pkgname-$pkgver.tar.gz
$pkgname.initd
"
-builddir="$srcdir/$pkgname-$pkgver"
-
build() {
- cd "$builddir"
./configure \
--prefix=/usr \
--sysconfdir=/etc/prosody \
@@ -41,12 +38,10 @@ build() {
}
check() {
- cd "$builddir"
/usr/bin/lua${_luaver} /usr/bin/busted --lua=/usr/bin/lua${_luaver}
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
install -d -o prosody -g prosody "$pkgdir/var/log/prosody"