aboutsummaryrefslogtreecommitdiffstats
path: root/community/psmisc/peekfd_lintl.patch
diff options
context:
space:
mode:
authorLeonardo Arena <rnalrd@alpinelinux.org>2017-04-07 15:02:16 +0000
committerLeonardo Arena <rnalrd@alpinelinux.org>2017-04-07 15:03:46 +0000
commit3c80ffcde355ba9c2b4629b4bdf3efef1278811a (patch)
treee294e4998e5dcbe0fb50d751ddf2325b13d6398f /community/psmisc/peekfd_lintl.patch
parent865fdb4dd3ee82b4930af7707486229aa4ee8283 (diff)
downloadaports-3c80ffcde355ba9c2b4629b4bdf3efef1278811a.tar.bz2
aports-3c80ffcde355ba9c2b4629b4bdf3efef1278811a.tar.xz
community/psmisc: fix build for ppc64le
https://github.com/leitao/aports/commit/9f4395581c9d594d2ffed51f2354c991e2c88c1a
Diffstat (limited to 'community/psmisc/peekfd_lintl.patch')
-rw-r--r--community/psmisc/peekfd_lintl.patch30
1 files changed, 30 insertions, 0 deletions
diff --git a/community/psmisc/peekfd_lintl.patch b/community/psmisc/peekfd_lintl.patch
new file mode 100644
index 0000000000..6d7ba1c227
--- /dev/null
+++ b/community/psmisc/peekfd_lintl.patch
@@ -0,0 +1,30 @@
+Author: Breno Leitao <brenohl@br.ibm.com>
+Date: Thu Apr 6 14:03:00 2017 -0300
+
+ pstree: Linking with libintl.
+
+ Curently pstree does built, at least on ppc64le, because it does
+ not have a explicit link against gettext, causing the following error:
+
+ peekfd.o: In function `print_version':
+ peekfd.c:(.text+0x160): undefined reference to `libintl_gettext'
+ peekfd.c:(.text+0x18c): undefined reference to `libintl_gettext'
+ peekfd.c:(.text+0x1ac): undefined reference to `libintl_gettext'
+
+ peekfd depends on libint because of the following macro:
+
+ #define _(String) gettext (String)
+
+Index: psmisc-22.21/src/Makefile.in
+===================================================================
+--- psmisc-22.21.orig/src/Makefile.in
++++ psmisc-22.21/src/Makefile.in
+@@ -131,7 +131,7 @@ killall_OBJECTS = $(am_killall_OBJECTS)
+ killall_DEPENDENCIES =
+ am_peekfd_OBJECTS = peekfd.$(OBJEXT)
+ peekfd_OBJECTS = $(am_peekfd_OBJECTS)
+-peekfd_LDADD = $(LDADD)
++peekfd_LDADD = $(LDADD) -lintl
+ am_prtstat_OBJECTS = prtstat.$(OBJEXT)
+ prtstat_OBJECTS = $(am_prtstat_OBJECTS)
+ prtstat_DEPENDENCIES =