aboutsummaryrefslogtreecommitdiffstats
path: root/community/psmisc
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-11-19 22:24:02 +0100
committerLeo <thinkabit.ukim@gmail.com>2019-11-19 22:24:19 +0100
commitb78188325ee5f07498f43bc60cc93b1ba785f13c (patch)
tree9d66602acaa5bbfed6022def5d46797479b8f103 /community/psmisc
parent9d13a86c8caced107d393081fb6a4fed9d412bc1 (diff)
downloadaports-b78188325ee5f07498f43bc60cc93b1ba785f13c.tar.bz2
aports-b78188325ee5f07498f43bc60cc93b1ba785f13c.tar.xz
main/psmisc: move from community
Diffstat (limited to 'community/psmisc')
-rw-r--r--community/psmisc/APKBUILD34
-rw-r--r--community/psmisc/include_limits.patch45
-rw-r--r--community/psmisc/musl_ptregs.patch20
3 files changed, 0 insertions, 99 deletions
diff --git a/community/psmisc/APKBUILD b/community/psmisc/APKBUILD
deleted file mode 100644
index b42ba3bfbd..0000000000
--- a/community/psmisc/APKBUILD
+++ /dev/null
@@ -1,34 +0,0 @@
-# Maintainer: Stuart Cardall <developer@it-offshore.co.uk>
-pkgname=psmisc
-pkgver=23.3
-pkgrel=0
-pkgdesc="A set of some small useful utilities that use the proc filesystem"
-url="http://psmisc.sourceforge.net/"
-arch="all"
-license="GPL-2.0-or-later"
-makedepends="gettext-dev libintl ncurses-dev"
-subpackages="$pkgname-doc $pkgname-lang"
-source="https://downloads.sourceforge.net/psmisc/psmisc-$pkgver.tar.xz
- include_limits.patch
- musl_ptregs.patch
- "
-
-build() {
- ./configure --prefix=/usr \
- --sysconfdir=/etc \
- --mandir=/usr/share/man \
- --infodir=/usr/share/info
- make
-}
-
-package() {
- make DESTDIR="$pkgdir" install
-}
-
-check() {
- make check
-}
-
-sha512sums="84e99ecb1d8125cb0adf34a76da21f75ed8498003a27941af0c1315853a95d3a0519d58ed21cc51c32327515670e745778a7eca02125d687498ee8ab1db4d238 psmisc-23.3.tar.xz
-63dea6a65c4cabcfa06d225950bc78fd6ac42f7445b8d10bde5e86dd8d96eb89823e486d7635b78562da058642f87289356c416225563a8e1ccfc2e32d81e884 include_limits.patch
-73dec9791e8cdb85cd3d9ef9be4d16e0fef481c6edc334ed9e954829444b1a92b87f7a3a2e6c1d09ac207bed828f214f5f2a95caa66540a7f2a6c58a6b8f6f2c musl_ptregs.patch"
diff --git a/community/psmisc/include_limits.patch b/community/psmisc/include_limits.patch
deleted file mode 100644
index 1b474bc8f6..0000000000
--- a/community/psmisc/include_limits.patch
+++ /dev/null
@@ -1,45 +0,0 @@
-Author: Breno Leitao <brenohl@br.ibm.com>
-Date: Thu Apr 6 13:59:57 2017 -0300
-
- peekfd: Include headers for ppc64
-
- Currently peekfd fails to build on ppc64le architecture with musl
- because it does not find reference for __WORDSIZE.
-
- This patch just includes reference for this macro if it was not
- previously defined.
-
-Index: psmisc-22.21/src/peekfd.c
-===================================================================
---- psmisc-22.21.orig/src/peekfd.c
-+++ psmisc-22.21/src/peekfd.c
-@@ -37,6 +37,14 @@
-
- #include "i18n.h"
-
-+#if !defined(PATH_MAX)
-+#include <limits.h>
-+#endif
-+
-+#if !defined(__WORDSIZE)
-+#include <bits/reg.h>
-+#endif
-+
- #ifdef I386
- #define REG_ORIG_ACCUM orig_eax
- #define REG_ACCUM eax
-Index: psmisc-22.21/src/pstree.c
-===================================================================
---- psmisc-22.21.orig/src/pstree.c
-+++ psmisc-22.21/src/pstree.c
-@@ -45,6 +45,10 @@
- #include "i18n.h"
- #include "comm.h"
-
-+#if !defined(PATH_MAX)
-+#include <limits.h>
-+#endif
-+
- #ifdef WITH_SELINUX
- #include <selinux/selinux.h>
- #else
diff --git a/community/psmisc/musl_ptregs.patch b/community/psmisc/musl_ptregs.patch
deleted file mode 100644
index 29fee6a2a1..0000000000
--- a/community/psmisc/musl_ptregs.patch
+++ /dev/null
@@ -1,20 +0,0 @@
-Author: Breno Leitao <brenohl@br.ibm.com>
-Date: Thu Apr 6 14:03:00 2017 -0300
-
- peekfd: Avoid pt_regs clash
-
-Index: psmisc-22.21/src/peekfd.c
-===================================================================
---- a/src/peekfd.c.old
-+++ b/src/peekfd.c
-@@ -27,7 +27,9 @@
- #include <sys/types.h>
- #include <sys/wait.h>
- #include <sys/syscall.h>
-+#define pt_regs uapi_pt_regs
- #include <asm/ptrace.h>
-+#undef pt_regs
- #include <byteswap.h>
- #include <endian.h>
- #include <sys/user.h>
-