aboutsummaryrefslogtreecommitdiffstats
path: root/community/pugixml
diff options
context:
space:
mode:
authorBart Ribbers <bribbers@disroot.org>2019-08-10 19:26:45 +0200
committerLeo <thinkabit.ukim@gmail.com>2019-08-10 14:48:46 -0300
commit7044ef90c932bf8c0707a8b32fa190bd5bab40d5 (patch)
tree2cfddad2b0ee64cffd87eff630fbb1ab80d35fdd /community/pugixml
parent99edc11a68461994d902fb373fe34eb290e313c2 (diff)
downloadaports-7044ef90c932bf8c0707a8b32fa190bd5bab40d5.tar.bz2
aports-7044ef90c932bf8c0707a8b32fa190bd5bab40d5.tar.xz
community/pugixml: install pkg-config file
Diffstat (limited to 'community/pugixml')
-rw-r--r--community/pugixml/APKBUILD14
-rw-r--r--community/pugixml/pkgconfig.patch72
2 files changed, 79 insertions, 7 deletions
diff --git a/community/pugixml/APKBUILD b/community/pugixml/APKBUILD
index 7642122d40..494fa81cf4 100644
--- a/community/pugixml/APKBUILD
+++ b/community/pugixml/APKBUILD
@@ -2,19 +2,19 @@
# Maintainer: Kevin Daudt <ops@ikke.info>
pkgname=pugixml
pkgver=1.9
-pkgrel=0
+pkgrel=1
pkgdesc="Light-weight, simple and fast XML parser for C++ with XPath support"
url="http://pugixml.org"
arch="all"
license="MIT"
makedepends="cmake"
subpackages="$pkgname-dev"
-source="http://github.com/zeux/pugixml/releases/download/v${pkgver}/pugixml-$pkgver.tar.gz"
-builddir="$srcdir/$pkgname-$pkgver"
+source="http://github.com/zeux/pugixml/releases/download/v${pkgver}/pugixml-$pkgver.tar.gz
+ pkgconfig.patch"
build() {
- cd "$builddir"
- cmake -DCMAKE_INSTALL_PREFIX=/usr \
+ cmake \
+ -DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib \
-DBUILD_SHARED_LIBS=True \
-DCMAKE_BUILD_TYPE=Release
@@ -22,8 +22,8 @@ build() {
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
}
-sha512sums="853a9d985aae537391c6524d5413ef4de237d99d96cc58ea7fe7152f786df1e408cdacd2e4387697e23c3e67cdc1d42b29de554501309eae16d86edd0e24785f pugixml-1.9.tar.gz"
+sha512sums="853a9d985aae537391c6524d5413ef4de237d99d96cc58ea7fe7152f786df1e408cdacd2e4387697e23c3e67cdc1d42b29de554501309eae16d86edd0e24785f pugixml-1.9.tar.gz
+5a170e9f9f0fa7f1b5db2942992bd7eab997f7d984bc383ef9864ba33c74085c8985b249fef930cc628346852f4ba87ce7c32842f9fe9a2483472e363ac3be4d pkgconfig.patch"
diff --git a/community/pugixml/pkgconfig.patch b/community/pugixml/pkgconfig.patch
new file mode 100644
index 0000000000..3a1d942d09
--- /dev/null
+++ b/community/pugixml/pkgconfig.patch
@@ -0,0 +1,72 @@
+From 314dc6a95baaca90294a8ea957d9810e3bee0f62 Mon Sep 17 00:00:00 2001
+From: Eli Schwartz <eschwartz93@gmail.com>
+Date: Mon, 9 Apr 2018 01:46:30 -0400
+Subject: [PATCH] cmake: always install the pkg-config file
+
+There's really never a reason to *not* want this installed. If an option
+is needed to specify installing in a versioned subdirectory, this option
+should be explicitly described rather than hidden in something else.
+
+As an added bonus, this makes the CMake install code slightly *less*
+complicated.
+---
+ CMakeLists.txt | 10 ++++------
+ scripts/pugixml.pc.in | 6 +++---
+ 2 files changed, 7 insertions(+), 9 deletions(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 90fa6793..d7bc1b20 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -4,7 +4,7 @@ project(pugixml)
+
+ option(BUILD_SHARED_LIBS "Build shared instead of static library" OFF)
+ option(BUILD_TESTS "Build tests" OFF)
+-option(BUILD_PKGCONFIG "Build in PKGCONFIG mode" OFF)
++option(USE_VERSIONED_LIBDIR "Use a private subdirectory to install the headers and libs" OFF)
+
+ set(BUILD_DEFINES "" CACHE STRING "Build defines")
+
+@@ -55,7 +55,7 @@ endif()
+ set_target_properties(pugixml PROPERTIES VERSION 1.9 SOVERSION 1)
+ get_target_property(PUGIXML_VERSION_STRING pugixml VERSION)
+
+-if(BUILD_PKGCONFIG)
++if(USE_VERSIONED_LIBDIR)
+ # Install library into its own directory under LIBDIR
+ set(INSTALL_SUFFIX /pugixml-${PUGIXML_VERSION_STRING})
+ endif()
+@@ -71,10 +71,8 @@ install(TARGETS pugixml EXPORT pugixml-config
+ install(FILES ${HEADERS} DESTINATION ${CMAKE_INSTALL_INCLUDEDIR}${INSTALL_SUFFIX})
+ install(EXPORT pugixml-config DESTINATION ${CMAKE_INSTALL_LIBDIR}/cmake/pugixml)
+
+-if(BUILD_PKGCONFIG)
+- configure_file(scripts/pugixml.pc.in ${PROJECT_BINARY_DIR}/pugixml.pc @ONLY)
+- install(FILES ${PROJECT_BINARY_DIR}/pugixml.pc DESTINATION ${CMAKE_INSTALL_PREFIX}/lib/pkgconfig)
+-endif()
++configure_file(scripts/pugixml.pc.in ${PROJECT_BINARY_DIR}/pugixml.pc @ONLY)
++install(FILES ${PROJECT_BINARY_DIR}/pugixml.pc DESTINATION ${CMAKE_INSTALL_PREFIX}/lib/pkgconfig)
+
+ if(BUILD_TESTS)
+ file(GLOB TEST_SOURCES tests/*.cpp)
+diff --git a/scripts/pugixml.pc.in b/scripts/pugixml.pc.in
+index 3c97c28d..804c4d38 100644
+--- a/scripts/pugixml.pc.in
++++ b/scripts/pugixml.pc.in
+@@ -1,11 +1,11 @@
+ prefix=@CMAKE_INSTALL_PREFIX@
+ exec_prefix=${prefix}
+-includedir=${prefix}/include/pugixml-@PUGIXML_VERSION_STRING@
+-libdir=${exec_prefix}/lib/pugixml-@PUGIXML_VERSION_STRING@
++includedir=${prefix}/include@INSTALL_SUFFIX@
++libdir=${exec_prefix}/lib@INSTALL_SUFFIX@
+
+ Name: pugixml
+ Description: Light-weight, simple and fast XML parser for C++ with XPath support.
+ URL: http://pugixml.org/
+ Version: @PUGIXML_VERSION_STRING@
+ Cflags: -I${includedir}
+-Libs: -L${libdir} -lpugixml
+\ No newline at end of file
++Libs: -L${libdir} -lpugixml
+