aboutsummaryrefslogtreecommitdiffstats
path: root/community/pulseaudio/APKBUILD
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-09-09 10:58:31 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-09-09 10:59:56 -0300
commit9ec2c7b66d59b8176c3e84201bffa9d6b86e3d85 (patch)
tree74ed0e007d4abc586f13b3c45bf7115825e0fa78 /community/pulseaudio/APKBUILD
parentf59ec79bc7152db87bac6aef3108898008e67789 (diff)
downloadaports-9ec2c7b66d59b8176c3e84201bffa9d6b86e3d85.tar.bz2
aports-9ec2c7b66d59b8176c3e84201bffa9d6b86e3d85.tar.xz
community/pulseaudio: install -openrc files
fixes #10781
Diffstat (limited to 'community/pulseaudio/APKBUILD')
-rw-r--r--community/pulseaudio/APKBUILD7
1 files changed, 4 insertions, 3 deletions
diff --git a/community/pulseaudio/APKBUILD b/community/pulseaudio/APKBUILD
index 068a73cf96..bc7392e462 100644
--- a/community/pulseaudio/APKBUILD
+++ b/community/pulseaudio/APKBUILD
@@ -5,7 +5,7 @@
# Maintainer: Leo <thinkabit.ukim@gmail.com>
pkgname=pulseaudio
pkgver=12.2
-pkgrel=4
+pkgrel=5
pkgdesc="A featureful, general-purpose sound server"
url="http://www.freedesktop.org/wiki/Software/PulseAudio"
arch="all"
@@ -71,13 +71,14 @@ check() {
package() {
make DESTDIR="$pkgdir" install
+
+ install -Dm644 "$srcdir"/$pkgname.initd "$pkgdir"/etc/init.d/$pkgname
+ install -Dm644 "$srcdir"/$pkgname.confd "$pkgdir"/etc/conf.d/$pkgname
}
openrc() {
replaces="$pkgname-system" # Backward compatibility
default_openrc
- mkdir -p "$subpkgdir"/etc
- mv "$pkgdir"/etc/dbus-1 "$subpkgdir"/etc
}
_libpulse() {