aboutsummaryrefslogtreecommitdiffstats
path: root/community/py-characteristic
diff options
context:
space:
mode:
authorFrancesco Colista <fcolista@alpinelinux.org>2016-08-22 09:27:38 +0000
committerFrancesco Colista <fcolista@alpinelinux.org>2016-08-22 10:14:49 +0000
commitff813591eea300f1fe7a1c8dc4807165a9da64dc (patch)
treeeb8073b493badedd510e0cd8282d877b09bebf94 /community/py-characteristic
parentde9b688cd246470be5812220acfdd15df2e09e7c (diff)
downloadaports-ff813591eea300f1fe7a1c8dc4807165a9da64dc.tar.bz2
aports-ff813591eea300f1fe7a1c8dc4807165a9da64dc.tar.xz
community/py-characteristic: moved from testing, added py2 and py3 subpackages
Diffstat (limited to 'community/py-characteristic')
-rw-r--r--community/py-characteristic/APKBUILD49
1 files changed, 49 insertions, 0 deletions
diff --git a/community/py-characteristic/APKBUILD b/community/py-characteristic/APKBUILD
new file mode 100644
index 0000000000..971507e5e2
--- /dev/null
+++ b/community/py-characteristic/APKBUILD
@@ -0,0 +1,49 @@
+# Contributor: Francesco Colista <fcolista@alpinelinux.org>
+# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
+pkgname=py-characteristic
+_pkgname=characteristic
+pkgver=14.3.0
+pkgrel=1
+pkgdesc="Service identity verification for pyOpenSSL"
+url="http://pypi.python.org/pypi/characteristic"
+arch="noarch"
+license="MIT"
+depends=""
+makedepends="py-setuptools py2-pytest python2-dev py3-pytest python3-dev"
+install=""
+subpackages="py3-${pkgname/py-/}:_py3 py2-${pkgname/py-/}:_py2"
+source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+
+builddir="$srcdir"/$_pkgname-$pkgver
+
+build() {
+ cd "$builddir"
+ python2 setup.py build || return 1
+ python3 setup.py build || return 1
+}
+
+package() {
+ mkdir -p "$pkgdir"
+}
+
+_py() {
+ local python=$1
+ pkgdesc="$pkgdesc - $python"
+ install_if="$pkgname=$pkgver-r$pkgrel $python"
+ cd "$builddir"
+ $python setup.py install --prefix=/usr --root="$subpkgdir"
+}
+
+_py2() {
+ _py python2
+ replaces="$pkgname"
+}
+
+_py3() {
+ _py python3
+}
+
+
+md5sums="b249368dd021fde1c06b4802867c0913 characteristic-14.3.0.tar.gz"
+sha256sums="ded68d4e424115ed44e5c83c2a901a0b6157a959079d7591d92106ffd3ada380 characteristic-14.3.0.tar.gz"
+sha512sums="e13a86f453cd3688a74188005b82a661a9c73d9f0408d9afe9e0575e69ffe87a5327f51e2c16a9c0a653b738e7c014d5aa08e353835f0aca7897714b7ae56e83 characteristic-14.3.0.tar.gz"