aboutsummaryrefslogtreecommitdiffstats
path: root/community/py-distutils-extra/APKBUILD
diff options
context:
space:
mode:
authorprspkt <prspkt@protonmail.com>2019-08-22 10:15:37 +0300
committerprspkt <prspkt@protonmail.com>2019-08-22 10:18:43 +0300
commit21c3eee4384443091a2045ce6277746c2c301b8d (patch)
treeb38c4ef76637abb0d000ba9769c05fa89ca4a32b /community/py-distutils-extra/APKBUILD
parent9d9bda7cee1a0fdfe9a466be6948b00c9dc45396 (diff)
downloadaports-21c3eee4384443091a2045ce6277746c2c301b8d.tar.bz2
aports-21c3eee4384443091a2045ce6277746c2c301b8d.tar.xz
community/py-distutils-extra: clarify license
* Modernize. * Fix runtime dependencies. Signed-off-by: prspkt <prspkt@protonmail.com>
Diffstat (limited to 'community/py-distutils-extra/APKBUILD')
-rw-r--r--community/py-distutils-extra/APKBUILD13
1 files changed, 6 insertions, 7 deletions
diff --git a/community/py-distutils-extra/APKBUILD b/community/py-distutils-extra/APKBUILD
index c7ccfa8adc..99525d6710 100644
--- a/community/py-distutils-extra/APKBUILD
+++ b/community/py-distutils-extra/APKBUILD
@@ -2,41 +2,40 @@
pkgname=py-distutils-extra
_pkgname=python-distutils-extra
pkgver=2.39
-pkgrel=4
+pkgrel=5
pkgdesc="Enhanced distutils package for python"
url="https://launchpad.net/python-distutils-extra"
arch="noarch"
-license="GPL"
+license="GPL-2.0-or-later"
depends="py-setuptools"
-makedepends="python2-dev python3-dev"
+makedepends="py2-setuptools py3-setuptools"
subpackages="py2-${pkgname#py-}:_py2 py3-${pkgname#py-}:_py3"
source="https://launchpad.net/python-distutils-extra/trunk/$pkgver/+download/$_pkgname-$pkgver.tar.gz"
builddir="$srcdir/$_pkgname-$pkgver"
build() {
- cd "$builddir"
python2 setup.py build
python3 setup.py build
}
check() {
- cd "$builddir"
python2 setup.py check
python3 setup.py check
}
package() {
- cd "$builddir"
mkdir -p "$pkgdir"
}
_py2() {
+ depends="${depends//py-/py2-}"
replaces="$pkgname"
_py python2
}
_py3() {
+ depends="${depends//py-/py3-}"
_py python3
}
@@ -47,7 +46,7 @@ _py() {
install_if="$pkgname=$pkgver-r$pkgrel $python"
cd "$builddir"
- $python setup.py install --root="$subpkgdir"
+ $python setup.py install --prefix=/usr --root="$subpkgdir"
}
sha512sums="e3b4d1ed22767fb4c6dbbdccef960865b6fda01d18dc38cb8f9357c09c7eabb78466fce053e407a196eca257d07d57c5c1ef47f358a5979c7f22e4b11775124e python-distutils-extra-2.39.tar.gz"