aboutsummaryrefslogtreecommitdiffstats
path: root/community/py-distutils-extra
diff options
context:
space:
mode:
authorRoberto Oliveira <robertoguimaraes8@gmail.com>2018-04-14 15:17:52 +0000
committerRoberto Oliveira <robertoguimaraes8@gmail.com>2018-04-14 15:17:52 +0000
commit85812ec2d5b141c966ec4065a7e3a5c425d5b76e (patch)
tree780fc79802cf2b5464cb395d367cdcb2565ae6f5 /community/py-distutils-extra
parent5ad73bb97b3eae826df384acd4574432d080b121 (diff)
downloadaports-85812ec2d5b141c966ec4065a7e3a5c425d5b76e.tar.bz2
aports-85812ec2d5b141c966ec4065a7e3a5c425d5b76e.tar.xz
community/py-distutils-extra: modernize abuild
Diffstat (limited to 'community/py-distutils-extra')
-rw-r--r--community/py-distutils-extra/APKBUILD28
1 files changed, 8 insertions, 20 deletions
diff --git a/community/py-distutils-extra/APKBUILD b/community/py-distutils-extra/APKBUILD
index 1a2ba8c02e..59efe7a572 100644
--- a/community/py-distutils-extra/APKBUILD
+++ b/community/py-distutils-extra/APKBUILD
@@ -1,38 +1,26 @@
# Contributor: William Pitcock <nenolod@dereferenced.org>
# Maintainer: William Pitcock <nenolod@dereferenced.org>
pkgname=py-distutils-extra
+_pkgname=python-distutils-extra
pkgver=2.39
-pkgrel=0
+pkgrel=1
pkgdesc="Enhanced distutils package for python"
url="https://launchpad.net/python-distutils-extra"
arch="noarch"
license="GPL"
depends="py-setuptools"
makedepends="python2-dev"
-install=""
-source="https://launchpad.net/python-distutils-extra/trunk/$pkgver/+download/python-distutils-extra-$pkgver.tar.gz"
-_builddir="$srcdir"/python-distutils-extra-$pkgver
-
-prepare() {
- local i
- cd "$_builddir"
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
-}
+source="https://launchpad.net/python-distutils-extra/trunk/$pkgver/+download/$_pkgname-$pkgver.tar.gz"
+builddir="$srcdir/$_pkgname-$pkgver"
build() {
- cd "$_builddir"
- python2 setup.py build || return 1
+ cd "$builddir"
+ python2 setup.py build
}
package() {
- cd "$_builddir"
- python2 setup.py install --root="$pkgdir" || return 1
+ cd "$builddir"
+ python2 setup.py install --root="$pkgdir"
}
-md5sums="16e06db0ef73a35b4bff4b9eed5699b5 python-distutils-extra-2.39.tar.gz"
-sha256sums="723f24f4d65fc8d99b33a002fbbb3771d4cc9d664c97085bf37f3997ae8063af python-distutils-extra-2.39.tar.gz"
sha512sums="e3b4d1ed22767fb4c6dbbdccef960865b6fda01d18dc38cb8f9357c09c7eabb78466fce053e407a196eca257d07d57c5c1ef47f358a5979c7f22e4b11775124e python-distutils-extra-2.39.tar.gz"