aboutsummaryrefslogtreecommitdiffstats
path: root/community/py-django1.5
diff options
context:
space:
mode:
authorChristian Kampka <christian@kampka.net>2016-07-16 20:18:56 +0200
committerChristian Kampka <christian@kampka.net>2016-07-16 20:18:56 +0200
commitfeea0cc49f772f13d93f67ae19ef541e8f16200b (patch)
tree9e63766ce64006cdece1580a680e4275915ea0db /community/py-django1.5
parentc2f163af5ce71021c968ae47f63c63cb2ed04ebc (diff)
downloadaports-feea0cc49f772f13d93f67ae19ef541e8f16200b.tar.bz2
aports-feea0cc49f772f13d93f67ae19ef541e8f16200b.tar.xz
main/py-django1.5: move to community
The py-django1.5 package is very much outdated and only dependet upon by community packages. Therefore, we move it to community for now but should get rid of it as soon as possible.
Diffstat (limited to 'community/py-django1.5')
-rw-r--r--community/py-django1.5/APKBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/community/py-django1.5/APKBUILD b/community/py-django1.5/APKBUILD
new file mode 100644
index 0000000000..0f9fb7e1f7
--- /dev/null
+++ b/community/py-django1.5/APKBUILD
@@ -0,0 +1,31 @@
+# Contributor: Andrew Wilcox <AWilcox@Wilcox-Tech.com>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=py-django1.5
+_pkgname=Django
+pkgver=1.5.12
+pkgrel=0
+pkgdesc="A high-level Python Web framework"
+url="http://djangoproject.com/"
+arch="noarch"
+license="BSD"
+depends="python"
+depends_dev=""
+makedepends="python-dev py-setuptools"
+install=""
+subpackages=""
+source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+
+_builddir="$srcdir"/$_pkgname-$pkgver
+build() {
+ cd "$_builddir"
+ python setup.py build || return 1
+}
+
+package() {
+ cd "$_builddir"
+ python setup.py install --root "$pkgdir" || return 1
+}
+
+md5sums="0e0b48cd0bb59cbc5499dcbb4fe1fb90 Django-1.5.12.tar.gz"
+sha256sums="b3de77beb6e59b72071ca66f20c2ad34e1b90d39b0241e62c1f03c668ddd6ced Django-1.5.12.tar.gz"
+sha512sums="37736827618737c54e7b63f2376b915d8dc0cdaf1900a2f6c3c9e0edd69e50379f95e3b6a31c930efdca88793b6330e7226175af91951d8637e5db780bc9fd8d Django-1.5.12.tar.gz"