aboutsummaryrefslogtreecommitdiffstats
path: root/community/py-ethtool
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-09-11 20:36:12 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-09-11 22:00:37 -0300
commitb33d8d8aa20976c9c5ab6cfb83ce3d8f55c9a4aa (patch)
treeb2e858cc79be3cd5a7b568311b9221084e4f0fb3 /community/py-ethtool
parent969d0bfc49cfe81c680bc4cd24602e8978172549 (diff)
downloadaports-b33d8d8aa20976c9c5ab6cfb83ce3d8f55c9a4aa.tar.bz2
aports-b33d8d8aa20976c9c5ab6cfb83ce3d8f55c9a4aa.tar.xz
community/py3-ethtool: rename from py-ethtool
Diffstat (limited to 'community/py-ethtool')
-rw-r--r--community/py-ethtool/APKBUILD68
-rw-r--r--community/py-ethtool/fix-includes-and-types.patch25
2 files changed, 0 insertions, 93 deletions
diff --git a/community/py-ethtool/APKBUILD b/community/py-ethtool/APKBUILD
deleted file mode 100644
index ed7bde5bb9..0000000000
--- a/community/py-ethtool/APKBUILD
+++ /dev/null
@@ -1,68 +0,0 @@
-# Maintainer: Leonardo Arena <rnalrd@alpinelinux.org>
-pkgname=py-ethtool
-_pkgname=ethtool
-pkgver=0.14
-pkgrel=2
-pkgdesc="Python library for the ethtool kernel interface"
-url="https://github.com/fedora-python/python-ethtool"
-arch="all"
-license="GPL-2.0-only"
-depends=
-makedepends="asciidoc libnl3-dev linux-headers py-setuptools python2-dev
- python3-dev"
-subpackages="py2-$_pkgname:_py2 py3-$_pkgname:_py3 $pkgname-doc"
-source="$pkgname-$pkgver.tar.gz::https://github.com/fedora-python/python-ethtool/archive/v$pkgver.tar.gz
- fix-includes-and-types.patch
- "
-builddir="$srcdir"/python-ethtool-$pkgver
-
-build() {
- cd "$builddir"
- python2 setup.py build
- python3 setup.py build
-
- # build man-pages
- a2x -d manpage -f manpage man/pethtool.8.asciidoc
- a2x -d manpage -f manpage man/pifconfig.8.asciidoc
-}
-
-package() {
- cd "$builddir"
- mkdir -p "$pkgdir"/usr/bin
-
- # install man-pages
- install -Dm644 man/*.8 -t "$pkgdir/usr/share/man/man8"
-
- # Create unsuffixed symlinks for executables from py3 subpackage
- local name; for name in pethtool pifconfig; do
- ln -s $name-3 "$pkgdir"/usr/bin/$name
- done
-}
-
-_py2() {
- replaces="$pkgname"
- _py python2
-}
-
-_py3() {
- _py python3
-}
-
-_py() {
- local python="$1"
- local pyver="${1:6:1}"
- pkgdesc="$pkgdesc (for $python)"
- depends="$depends $python"
- install_if="$pkgname=$pkgver-r$pkgrel $python"
-
- cd "$builddir"
- $python setup.py install --prefix=/usr --root="$subpkgdir"
-
- # Add version suffix to executable files
- local path; for path in "$subpkgdir"/usr/bin/*; do
- mv "$path" "$path-$pyver"
- done
-}
-
-sha512sums="57a3f2d60dd8309192fc858614645d4e7533c90c03113ffc1eeeb810b86eb71b0a80b4eb209d3452c7624c5318a853de50d9d716d41334bf079e6e3e2490fd4b py-ethtool-0.14.tar.gz
-847d7468b5897746d9bfa89d69630629b391f786c89a5d4602768bc3d5bfa84439af5cbf6832ce9b242af374031a2125c5cf119e0af93cb6f2764b238eb60828 fix-includes-and-types.patch"
diff --git a/community/py-ethtool/fix-includes-and-types.patch b/community/py-ethtool/fix-includes-and-types.patch
deleted file mode 100644
index 4562ce44ad..0000000000
--- a/community/py-ethtool/fix-includes-and-types.patch
+++ /dev/null
@@ -1,25 +0,0 @@
---- a/python-ethtool/etherinfo.c
-+++ b/python-ethtool/etherinfo.c
-@@ -18,7 +18,6 @@
- #include <Python.h>
- #include "include/py3c/compat.h"
- #include <bytesobject.h>
--#include <bits/sockaddr.h>
- #include <stdio.h>
- #include <string.h>
- #include <sys/types.h>
---- a/python-ethtool/ethtool.c
-+++ b/python-ethtool/ethtool.c
-@@ -45,9 +45,9 @@
- #endif
-
- typedef unsigned long long u64;
--typedef __uint32_t u32;
--typedef __uint16_t u16;
--typedef __uint8_t u8;
-+typedef uint32_t u32;
-+typedef uint16_t u16;
-+typedef uint8_t u8;
-
- #include "ethtool-copy.h"
- #include <linux/sockios.h> /* for SIOCETHTOOL */