aboutsummaryrefslogtreecommitdiffstats
path: root/community/py-eyed3
diff options
context:
space:
mode:
authorprspkt <prspkt@protonmail.com>2018-07-16 17:18:07 +0300
committerNatanael Copa <ncopa@alpinelinux.org>2018-08-16 20:50:38 +0000
commit2a65caec2d689436a77f4cec1dbffb1979ff15e8 (patch)
treec078ffba60b6172d7b49a441380a74d0e0d078d1 /community/py-eyed3
parentf0d04082dfafa09d3512bfab85f371578fc5caa5 (diff)
downloadaports-2a65caec2d689436a77f4cec1dbffb1979ff15e8.tar.bz2
aports-2a65caec2d689436a77f4cec1dbffb1979ff15e8.tar.xz
main/py-eyed3: claim maintainership, move to community
Diffstat (limited to 'community/py-eyed3')
-rw-r--r--community/py-eyed3/APKBUILD44
-rw-r--r--community/py-eyed3/eyeD3-sh.patch7
2 files changed, 51 insertions, 0 deletions
diff --git a/community/py-eyed3/APKBUILD b/community/py-eyed3/APKBUILD
new file mode 100644
index 0000000000..5f86a2e6a5
--- /dev/null
+++ b/community/py-eyed3/APKBUILD
@@ -0,0 +1,44 @@
+# Maintainer: prspkt <prspkt@protonmail.com>
+pkgname=py-eyed3
+_pkgname=eyeD3
+pkgver=0.7.8
+pkgrel=1
+pkgdesc="A Python module and program for processing information about mp3 files"
+url="http://eyed3.nicfit.net/"
+arch="noarch"
+license="GPL"
+depends="python2"
+depends_dev=""
+makedepends="python2-dev py-setuptools"
+install=""
+subpackages=""
+source="http://eyed3.nicfit.net/releases/$_pkgname-$pkgver.tar.gz
+ eyeD3-sh.patch"
+
+_builddir="$srcdir"/$_pkgname-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ python2 setup.py build || return 1
+}
+
+package() {
+ cd "$_builddir"
+ python2 setup.py install --prefix=/usr --root="$pkgdir" || return 1
+}
+
+md5sums="2783538edb56d7f583b7c8a5801b51dc eyeD3-0.7.8.tar.gz
+71fa0586d5521bc86778a87d5d3be924 eyeD3-sh.patch"
+sha256sums="06b956572b8d63c52db8f62447277a5647fc185b7afef9f2a918b4601db467db eyeD3-0.7.8.tar.gz
+de5176e0d1e60854195954baf8fda6426abe5409cb5affcbd732f469b2f986f7 eyeD3-sh.patch"
+sha512sums="fa0f5302f8da0ca15cd3047f97e457a8f96ed6b2d6c03bba3d0e94a11bf093c503c5ffd4cbc9191f00eeeb090e7c9ab1689c9c1b2217ddb69e41251fefabdade eyeD3-0.7.8.tar.gz
+bebc7e834efe259397a397bf8024e52f41893e6eeb4a3fa2b4e00d1559fbcca27d25576dada0e10857512ac111738fdd89a3b6ae6b025b847690ba5b76fce3e4 eyeD3-sh.patch"
diff --git a/community/py-eyed3/eyeD3-sh.patch b/community/py-eyed3/eyeD3-sh.patch
new file mode 100644
index 0000000000..1f9798834b
--- /dev/null
+++ b/community/py-eyed3/eyeD3-sh.patch
@@ -0,0 +1,7 @@
+--- a/bin/eyeD3 2014-10-24 11:11:12.104828448 +0500
++++ b/bin/eyeD3 2014-10-24 11:11:24.744759113 +0500
+@@ -1,3 +1,3 @@
+-#!/usr/bin/env bash
++#!/bin/sh
+
+ python -m eyed3.main "$@"