aboutsummaryrefslogtreecommitdiffstats
path: root/community/py-jedi
diff options
context:
space:
mode:
authorKevin Daudt <kdaudt@alpinelinux.org>2019-04-02 21:34:10 +0000
committerKevin Daudt <kdaudt@alpinelinux.org>2019-04-02 21:37:44 +0000
commit762ab745234ce1bd1ddf4352c423ac21499e55c4 (patch)
treed649700f2f6fa480c41a85d151ecfa1290edc191 /community/py-jedi
parent314b24d565fc782675582fcedf74add802a5fc8c (diff)
downloadaports-762ab745234ce1bd1ddf4352c423ac21499e55c4.tar.bz2
aports-762ab745234ce1bd1ddf4352c423ac21499e55c4.tar.xz
community/py-jedi: fix test_os_path_join on aarch64
The test takes slightly longer on aarch64 then the test allows. Issue: https://github.com/davidhalter/jedi/issues/1306
Diffstat (limited to 'community/py-jedi')
-rw-r--r--community/py-jedi/APKBUILD6
-rw-r--r--community/py-jedi/adjust-speed-test.patch15
2 files changed, 19 insertions, 2 deletions
diff --git a/community/py-jedi/APKBUILD b/community/py-jedi/APKBUILD
index b649c4489b..ff524fa832 100644
--- a/community/py-jedi/APKBUILD
+++ b/community/py-jedi/APKBUILD
@@ -10,7 +10,8 @@ arch="noarch"
license="MIT"
makedepends="py3-setuptools python3-dev"
checkdepends="pytest py-parso py-tox"
-source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz
+ adjust-speed-test.patch"
builddir="$srcdir"/$_pkgname-$pkgver
replaces="py3-jedi"
@@ -30,4 +31,5 @@ package() {
python3 setup.py install --prefix=/usr --root="$pkgdir"
}
-sha512sums="b20fc75d909f9b7c6db434f468e7cefd9768991ca72d7026df9c4000805675a979f9e40f75623770df44bf8919a46270bcaa8e28d991a2299c64bc4c60d873fc jedi-0.13.3.tar.gz"
+sha512sums="b20fc75d909f9b7c6db434f468e7cefd9768991ca72d7026df9c4000805675a979f9e40f75623770df44bf8919a46270bcaa8e28d991a2299c64bc4c60d873fc jedi-0.13.3.tar.gz
+8a33c01f8d9f4f121176b0346759e74ab9847f1803f9d82515826c470822bf35ca5c84c29ac0c65b244457f8a05e26e05f6182337eadaf2aa4acc80a88972e32 adjust-speed-test.patch"
diff --git a/community/py-jedi/adjust-speed-test.patch b/community/py-jedi/adjust-speed-test.patch
new file mode 100644
index 0000000000..0a95cacfec
--- /dev/null
+++ b/community/py-jedi/adjust-speed-test.patch
@@ -0,0 +1,15 @@
+On aarch64, this tests takes ~0.4s, which is larger than the default
+threshold. Increase it a bit to let this test pass.
+diff --git a/test/test_speed.py b/test/test_speed.py
+index f3fa7c7b3d..ba5784acc8 100644
+--- a/test/test_speed.py
++++ b/test/test_speed.py
+@@ -30,7 +30,7 @@ def _check_speed(time_per_run, number=4, run_warm=True):
+ return decorated
+
+
+-@_check_speed(0.3)
++@_check_speed(0.5)
+ def test_os_path_join(Script):
+ s = "from posixpath import join; join('', '')."
+ assert len(Script(s).completions()) > 10 # is a str completion