aboutsummaryrefslogtreecommitdiffstats
path: root/community/py-lz4
diff options
context:
space:
mode:
authorStuart Cardall <developer@it-offshore.co.uk>2017-12-22 16:12:30 +0000
committerJakub Jirutka <jakub@jirutka.cz>2017-12-27 15:14:34 +0100
commit3c59c683d1ee84c01bcd2c34076d7caa471b9ca6 (patch)
tree00eb3d01f49a7fa1292252708fdf75961f42b1f3 /community/py-lz4
parent3e53157751156c0e8f466ba5de60a23d15cffe4b (diff)
downloadaports-3c59c683d1ee84c01bcd2c34076d7caa471b9ca6.tar.bz2
aports-3c59c683d1ee84c01bcd2c34076d7caa471b9ca6.tar.xz
community/py-lz4: upgrade to 0.13.0
Diffstat (limited to 'community/py-lz4')
-rw-r--r--community/py-lz4/APKBUILD26
-rw-r--r--community/py-lz4/disable-failing-test.patch42
2 files changed, 10 insertions, 58 deletions
diff --git a/community/py-lz4/APKBUILD b/community/py-lz4/APKBUILD
index b1991324b0..ba873dcb17 100644
--- a/community/py-lz4/APKBUILD
+++ b/community/py-lz4/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Stuart Cardall <developer@it-offshore.co.uk>
# Maintainer: Stuart Cardall <developer@it-offshore.co.uk>
pkgname=py-lz4
-pkgver=0.11.1
+pkgver=0.13.0
_pkgname=${pkgname#py-}
pkgrel=0
pkgdesc="LZ4 Bindings for Python"
@@ -16,16 +16,18 @@ if [ "$CARCH" = "s390x" ]; then
options="!check"
fi
subpackages="py3-${pkgname/py-/}:_py3 py2-${pkgname/py-/}:_py2 $pkgname-tests:_tests:noarch"
-source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz
- disable-failing-test.patch
- "
-
+source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
builddir="$srcdir/$_pkgname-$pkgver"
build() {
cd "$builddir"
- python2 setup.py build || return 1
- python3 setup.py build || return 1
+ python2 setup.py build
+ python3 setup.py build
+}
+
+check() {
+ cd "$builddir"
+ python2 setup.py test
}
package() {
@@ -58,12 +60,4 @@ _tests() {
mv "$builddir"/tests "$subpkgdir"/usr/share/$pkgname
}
-check() {
- cd "$builddir"
- # issue opened for failing test:
- # https://github.com/python-lz4/python-lz4/issues/19
- python setup.py test
-}
-
-sha512sums="7b1c952dccb1fc1436396f1642db91d63fa11aaf992d7adf72891bfa5ad83c767e96c2d9a31bf444b1eda74430e456e228dfdea291ee8f5c471c13f146988671 lz4-0.11.1.tar.gz
-6fb99988e604a3a2f72d6297d2c0596586bdf7cc66c740061c362502de04a2fe9f814708c5722874b45df6cddd14303a3920de1249ca3b98a5a8eb19bb981a04 disable-failing-test.patch"
+sha512sums="0175838981e21301c20b64e02959c73723d9de629fb8dc10ea745b0ef5a5de95d37f5abe1e7b2c104658b3ebd66a84ef948b7ff3e2eb556162e9e0e5fbd4c9ff lz4-0.13.0.tar.gz"
diff --git a/community/py-lz4/disable-failing-test.patch b/community/py-lz4/disable-failing-test.patch
deleted file mode 100644
index 7e658ff707..0000000000
--- a/community/py-lz4/disable-failing-test.patch
+++ /dev/null
@@ -1,42 +0,0 @@
-# issue opened: https://github.com/python-lz4/python-lz4/issues/19
-
---- lz4-0.9.0/tests/test_frame.py.orig
-+++ lz4-0.9.0/tests/test_frame.py
-@@ -211,37 +211,6 @@
- pool.close()
- self.assertEqual(data, out)
-
-- def test_compress_begin_update_end_no_auto_flush_not_defaults_threaded(self):
-- data = [os.urandom(3 * 256 * 1024) for i in range(100)]
--
-- def roundtrip(x):
-- context = lz4frame.create_compression_context()
-- self.assertNotEqual(context, None)
-- compressed = lz4frame.compress_begin(
-- context,
-- block_size=lz4frame.BLOCKSIZE_MAX256KB,
-- block_mode=lz4frame.BLOCKMODE_LINKED,
-- compression_level=lz4frame.COMPRESSIONLEVEL_MAX,
-- auto_flush=0
-- )
-- chunk_size = 128 * 1024 # 128 kb, half of block size
-- start = 0
-- end = start + chunk_size
--
-- while start <= len(x):
-- compressed += lz4frame.compress_update(context, x[start:end])
-- start = end
-- end = start + chunk_size
--
-- compressed += lz4frame.compress_end(context)
-- decompressed = lz4frame.decompress(compressed)
-- return decompressed
--
-- pool = ThreadPool(8)
-- out = pool.map(roundtrip, data)
-- pool.close()
-- self.assertEqual(data, out)
--
- def test_LZ4FrameCompressor(self):
- input_data = b"2099023098234882923049823094823094898239230982349081231290381209380981203981209381238901283098908123109238098123"
- with lz4frame.LZ4FrameCompressor() as compressor: