aboutsummaryrefslogtreecommitdiffstats
path: root/community/py-packaging
diff options
context:
space:
mode:
authorWilliam Pitcock <nenolod@dereferenced.org>2017-04-15 21:45:22 +0000
committerWilliam Pitcock <nenolod@dereferenced.org>2017-04-15 21:45:22 +0000
commit97a3ddf98567eb8073aeca6cd73d3f2877eeeca7 (patch)
treeb37cf9ecf33b41e6fd3198a1e74496abac8ac688 /community/py-packaging
parenta5c55fae732ea6706d0a60b15689f6affb11b050 (diff)
downloadaports-97a3ddf98567eb8073aeca6cd73d3f2877eeeca7.tar.bz2
aports-97a3ddf98567eb8073aeca6cd73d3f2877eeeca7.tar.xz
testing/py-packaging: move to community
Diffstat (limited to 'community/py-packaging')
-rw-r--r--community/py-packaging/APKBUILD49
1 files changed, 49 insertions, 0 deletions
diff --git a/community/py-packaging/APKBUILD b/community/py-packaging/APKBUILD
new file mode 100644
index 0000000000..f48c560419
--- /dev/null
+++ b/community/py-packaging/APKBUILD
@@ -0,0 +1,49 @@
+# Maintainer: Breno Leitao <breno.leitao@gmail.com>
+pkgname=py-packaging
+_pkgname=packaging
+pkgver=16.8
+pkgrel=1
+pkgdesc="Core utilities for Python packages"
+url="https://pypi.python.org/pypi/packaging"
+arch="noarch"
+license="APACHE or BSD"
+depends="py-parsing py-six"
+subpackages="py2-${pkgname#py-}:_py2 py3-${pkgname#py-}:_py3"
+makedepends="python3-dev python2-dev py-setuptools"
+source="https://files.pythonhosted.org/packages/source/p/$_pkgname/$_pkgname-$pkgver.tar.gz"
+builddir="$srcdir/$_pkgname-$pkgver"
+
+build() {
+ cd "$builddir"
+ python2 setup.py build || return 1
+ python3 setup.py build || return 1
+}
+
+package() {
+ mkdir -p "$pkgdir"
+}
+
+
+_py2() {
+ replaces="$pkgname"
+ depends="${depends//py-/py2-}"
+ _py python2
+}
+
+_py3() {
+ depends="${depends//py-/py3-}"
+ _py python3
+}
+
+_py() {
+ local python="$1"
+ pkgdesc="$pkgdesc (for $python)"
+ depends="$depends $python"
+ install_if="$pkgname=$pkgver-r$pkgrel $python"
+
+ cd "$builddir"
+ $python setup.py install --prefix=/usr --root="$subpkgdir"
+}
+
+
+sha512sums="d1a7b65472c7c02dd758f0c469d6c6aeea34de7b798613f7fcdf45fcccbeba1e9085cab113fa89b392a60f758f8747d13b1c265c809566990c22e61ca8db49bb packaging-16.8.tar.gz"