aboutsummaryrefslogtreecommitdiffstats
path: root/community/py-psutil
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2016-11-07 00:02:33 +0100
committerJakub Jirutka <jakub@jirutka.cz>2016-11-07 00:02:33 +0100
commitd443f4aba9641ee0a20d608b03e3156875a1513a (patch)
tree14697758720d7007e45412a36bd821ec1c082fce /community/py-psutil
parent8e325ab8c9fa1852c65ed3c88f3cbe2689e4d8ae (diff)
downloadaports-d443f4aba9641ee0a20d608b03e3156875a1513a.tar.bz2
aports-d443f4aba9641ee0a20d608b03e3156875a1513a.tar.xz
community/py-psutil: improve abuild
Diffstat (limited to 'community/py-psutil')
-rw-r--r--community/py-psutil/APKBUILD15
1 files changed, 6 insertions, 9 deletions
diff --git a/community/py-psutil/APKBUILD b/community/py-psutil/APKBUILD
index 529cd8134e..dd0a6b4f34 100644
--- a/community/py-psutil/APKBUILD
+++ b/community/py-psutil/APKBUILD
@@ -10,15 +10,14 @@ arch="all"
license="BSD"
depends=""
makedepends="$depends_dev linux-headers python2-dev python3-dev"
-install=""
subpackages="py3-$_pkgname:_py3 py2-$_pkgname:_py2"
source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.zip"
+builddir="$srcdir/$_pkgname-$pkgver"
-builddir="$srcdir"/$_pkgname-$pkgver
build() {
cd "$builddir"
python2 setup.py build || return 1
- python3 setup.py build || return 1
+ python3 setup.py build || return 1
}
package() {
@@ -26,25 +25,23 @@ package() {
}
_py() {
- local python=$1
+ local python="$1"
pkgdesc="$pkgdesc - $python"
- install_if="$pkgname=$pkgver-r$pkgrel $python"
+ install_if="$pkgname=$pkgver-r$pkgrel $python"
+
cd "$builddir"
$python setup.py install --prefix=/usr --root="$subpkgdir"
}
_py2() {
- _py python2
replaces="$pkgname"
+ _py python2
}
_py3() {
_py python3
}
-
-
-
md5sums="362a03686ce36940d22a548ecb47d7e0 psutil-5.0.0.zip"
sha256sums="5411e22c63168220f4b8cc42fd05ea96f5b5e65e08b93b675ca50653aea482f8 psutil-5.0.0.zip"
sha512sums="fda1e6b0a1d54943ceb6e94b4f892d3a3758d947589fd2ada5631f9cfffec4ab7925632d814572cef527b437ea24e0a37244475d634fe86cc0daf5adc2933b27 psutil-5.0.0.zip"