aboutsummaryrefslogtreecommitdiffstats
path: root/community/py-pyflakes
diff options
context:
space:
mode:
authorKeith Maxwell <keith.maxwell@gmail.com>2019-04-15 14:24:57 +0100
committerNatanael Copa <ncopa@alpinelinux.org>2019-04-16 09:58:31 +0000
commit8630b2a7efadfb1cc029252e2530939c4707dfe8 (patch)
tree9f662e378c54fcad8305dd6309427275c9901f0a /community/py-pyflakes
parent490080846d8da5876850a98595d0383ea8a67770 (diff)
downloadaports-8630b2a7efadfb1cc029252e2530939c4707dfe8.tar.bz2
aports-8630b2a7efadfb1cc029252e2530939c4707dfe8.tar.xz
community/py-pyflakes: upgrade to 2.1.1
Also remove two bashisms - string indexing - see links below for a description: https://wiki.ubuntu.com/DashAsBinSh#A.24.7Bfoo:3.5B:1.5D.7D https://github.com/koalaman/shellcheck/wiki/SC2039#var1-substring-expansion
Diffstat (limited to 'community/py-pyflakes')
-rw-r--r--community/py-pyflakes/APKBUILD8
1 files changed, 4 insertions, 4 deletions
diff --git a/community/py-pyflakes/APKBUILD b/community/py-pyflakes/APKBUILD
index 0972cc5500..eb2369b730 100644
--- a/community/py-pyflakes/APKBUILD
+++ b/community/py-pyflakes/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
pkgname=py-pyflakes
_pkgname=${pkgname#py-}
-pkgver=1.6.0
+pkgver=2.1.1
pkgrel=3
pkgdesc="A passive checker of Python programs"
url="https://github.com/pyflakes/pyflakes"
@@ -10,7 +10,7 @@ arch="noarch"
license="MIT"
makedepends="python2-dev python3-dev py-setuptools"
subpackages="py3-$_pkgname:_py3 py2-$_pkgname:_py2"
-source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+source="https://files.pythonhosted.org/packages/source/p/$_pkgname/$_pkgname-$pkgver.tar.gz"
builddir="$srcdir/$_pkgname-$pkgver"
build() {
@@ -44,7 +44,7 @@ _py3() {
_py() {
local python="$1"
- local pyver="${1:6:1}"
+ local pyver="${1#python}"
pkgdesc="$pkgdesc (for $python)"
depends="$python"
install_if="$pkgname=$pkgver-r$pkgrel $python"
@@ -58,4 +58,4 @@ _py() {
done
}
-sha512sums="7e9c2aad6ebed638a1354cef51c7e1f68b25e59f8caf4694997a9afecd7cd8baa629a9363297ac0d961430f007fd22dcae7dae1bcbd7838a3b5d4285063bc7c5 pyflakes-1.6.0.tar.gz"
+sha512sums="7ebf5843b38146305c1063e070480fea8ec3b47fa1be546b1fafaeb242a688a5a001f978e7257fd71d5905b9a338b466ef17c7330725191587e9c40ba632c3f8 pyflakes-2.1.1.tar.gz"