aboutsummaryrefslogtreecommitdiffstats
path: root/community/py-setuptools_scm/APKBUILD
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-06-14 17:59:50 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-06-14 17:59:50 -0300
commit746e972767da85bcd73f67992fd4b1e188cd9bb4 (patch)
treef804a30a31e3a09a213379b26f6ef4a110c6c388 /community/py-setuptools_scm/APKBUILD
parent134a01279b0dd3fbabd7f81fe28fabcee64adfc6 (diff)
downloadaports-746e972767da85bcd73f67992fd4b1e188cd9bb4.tar.bz2
aports-746e972767da85bcd73f67992fd4b1e188cd9bb4.tar.xz
community/py-setuptools_scm: modernize
Diffstat (limited to 'community/py-setuptools_scm/APKBUILD')
-rw-r--r--community/py-setuptools_scm/APKBUILD9
1 files changed, 3 insertions, 6 deletions
diff --git a/community/py-setuptools_scm/APKBUILD b/community/py-setuptools_scm/APKBUILD
index 20d77a9cb6..d53651f95f 100644
--- a/community/py-setuptools_scm/APKBUILD
+++ b/community/py-setuptools_scm/APKBUILD
@@ -8,23 +8,20 @@ pkgdesc="the blessed package to manage your versions by scm tags"
url="https://github.com/pypa/setuptools_scm"
arch="noarch"
license="MIT"
-depends=""
checkdepends="pytest py-pip mercurial"
-makedepends="python2-dev python3-dev py-setuptools"
+makedepends="py-setuptools py3-setuptools"
subpackages="py3-$_pkgname:_py3 py2-$_pkgname:_py2"
source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
builddir="$srcdir"/$_pkgname-$pkgver
build() {
- cd "$builddir"
python2 setup.py build
python3 setup.py build
}
check() {
- cd "$builddir"
- PYTHONPATH=$PWD/src python2 -m pytest
- PYTHONPATH=$PWD/src python3 -m pytest
+ PYTHONPATH=$PWD/src python2 -m pytest
+ PYTHONPATH=$PWD/src python3 -m pytest
}
package() {