aboutsummaryrefslogtreecommitdiffstats
path: root/community/py-sqlparse
diff options
context:
space:
mode:
authorJ0WI <J0WI@users.noreply.github.com>2018-10-24 21:31:48 +0200
committerAndy Postnikov <apostnikov@gmail.com>2018-10-25 12:45:09 +0300
commit1c44ac7d9423b0a63729eb9009df0fb2bede3c67 (patch)
tree8613638b2936b196e9e573620c53991649fe2a42 /community/py-sqlparse
parent5d9467cb6097b1557f478ae721b5192690a965f2 (diff)
downloadaports-1c44ac7d9423b0a63729eb9009df0fb2bede3c67.tar.bz2
aports-1c44ac7d9423b0a63729eb9009df0fb2bede3c67.tar.xz
community/py-sqlparse: add check routine
Diffstat (limited to 'community/py-sqlparse')
-rw-r--r--community/py-sqlparse/APKBUILD7
1 files changed, 7 insertions, 0 deletions
diff --git a/community/py-sqlparse/APKBUILD b/community/py-sqlparse/APKBUILD
index 6567d1262c..a495d33ead 100644
--- a/community/py-sqlparse/APKBUILD
+++ b/community/py-sqlparse/APKBUILD
@@ -9,6 +9,7 @@ url="https://sqlparse.readthedocs.io"
arch="noarch"
license="BSD"
depends=""
+checkdepends="pytest"
makedepends="python2-dev py-setuptools python3-dev"
subpackages="py2-${pkgname#py-}:_py2 py3-${pkgname#py-}:_py3"
source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
@@ -20,6 +21,12 @@ build() {
python3 setup.py build
}
+check() {
+ cd "$builddir"
+ python2 -m pytest .
+ python3 -m pytest .
+}
+
package() {
mkdir -p "$pkgdir"/usr/bin
ln -s sqlformat-3 "$pkgdir"/usr/bin/sqlformat