aboutsummaryrefslogtreecommitdiffstats
path: root/community/py-websocket-client/APKBUILD
diff options
context:
space:
mode:
authorFrancesco Colista <fcolista@alpinelinux.org>2017-06-19 08:35:09 +0000
committerFrancesco Colista <fcolista@alpinelinux.org>2017-06-19 08:35:09 +0000
commitb7b12019f7674a67d639505fff7fa082b0d73979 (patch)
tree7aa50fde118dd3e7f5ace56c20ec5a896a40da53 /community/py-websocket-client/APKBUILD
parent86500b32e182c84a986f974c3e1d5cd6fcc0613c (diff)
downloadaports-b7b12019f7674a67d639505fff7fa082b0d73979.tar.bz2
aports-b7b12019f7674a67d639505fff7fa082b0d73979.tar.xz
community/py-websocket-client: upgrade to 0.42.1
Diffstat (limited to 'community/py-websocket-client/APKBUILD')
-rw-r--r--community/py-websocket-client/APKBUILD19
1 files changed, 10 insertions, 9 deletions
diff --git a/community/py-websocket-client/APKBUILD b/community/py-websocket-client/APKBUILD
index 25075a98dc..314c8c576b 100644
--- a/community/py-websocket-client/APKBUILD
+++ b/community/py-websocket-client/APKBUILD
@@ -2,24 +2,27 @@
# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
pkgname=py-websocket-client
_pkgname=websocket_client
-pkgver=0.40.0
+pkgver=0.42.1
pkgrel=0
pkgdesc="WebSocket client library for Python"
url="https://github.com/liris/websocket-client"
arch="noarch"
license="LGPL"
-depends=""
makedepends="python2-dev python3-dev py-setuptools py2-six py3-six"
-install=""
subpackages="py3-${pkgname/py-/}:_py3 py2-${pkgname/py-/}:_py2"
source="https://files.pythonhosted.org/packages/source/w/websocket-client/$_pkgname-$pkgver.tar.gz"
-
builddir="$srcdir"/$_pkgname-$pkgver
+check() {
+ cd "$builddir"
+ python2 setup.py check
+ python3 setup.py check
+}
+
build() {
cd "$builddir"
- python2 setup.py build || return 1
- python3 setup.py build || return 1
+ python2 setup.py build
+ python3 setup.py build
}
package() {
@@ -43,6 +46,4 @@ _py3() {
_py python3
}
-md5sums="f1cf4cc7869ef97a98e5f4be25c30986 websocket_client-0.40.0.tar.gz"
-sha256sums="40ac14a0c54e14d22809a5c8d553de5a2ae45de3c60105fae53bcb281b3fe6fb websocket_client-0.40.0.tar.gz"
-sha512sums="b57593e14087ff36ab2133fb8077aa207bcdcc04fa82d00eb8fa3b86bdf7fa949c8ca25317a7fe035ef0f36d2c996e036d2b715399813604d5593584d409a5eb websocket_client-0.40.0.tar.gz"
+sha512sums="af776e73280f11209d06c8cbf7719d45c50d0a83002b960571f75b60b902666cf994a94b1def80323c8115a76e4d3958c6c2f88a9da4383406ae2db62a057e93 websocket_client-0.42.1.tar.gz"