aboutsummaryrefslogtreecommitdiffstats
path: root/community/py-zope-component
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-09-07 07:02:53 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-09-07 07:17:21 -0300
commitf6dc0966a4c1c3e67cc6e6baee047c8da750b300 (patch)
treec0c2e186f45c04127cbbdc98d7bdddaf6053468a /community/py-zope-component
parent8f2e297258f2dea4a61c3ba35fdfd26ec8ca1799 (diff)
downloadaports-f6dc0966a4c1c3e67cc6e6baee047c8da750b300.tar.bz2
aports-f6dc0966a4c1c3e67cc6e6baee047c8da750b300.tar.xz
community/py3-zope-component: rename from py-zope-component
Diffstat (limited to 'community/py-zope-component')
-rw-r--r--community/py-zope-component/APKBUILD59
1 files changed, 0 insertions, 59 deletions
diff --git a/community/py-zope-component/APKBUILD b/community/py-zope-component/APKBUILD
deleted file mode 100644
index 5e7710cadb..0000000000
--- a/community/py-zope-component/APKBUILD
+++ /dev/null
@@ -1,59 +0,0 @@
-# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
-# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
-pkgname=py-zope-component
-_pkgname=zope.component
-pkgver=4.5
-pkgrel=2
-pkgdesc="Zope Component Architecture"
-url="https://pypi.python.org/pypi/zope.component"
-arch="noarch"
-license="ZPL-2.1"
-depends="
- py-setuptools
- py-zope-deferredimport
- py-zope-deprecation
- py-zope-event
- py-zope-hookable
- py-zope-interface
- "
-makedepends="python2-dev python3-dev libffi-dev"
-subpackages="py2-${pkgname#py-}:_py2 py3-${pkgname#py-}:_py3"
-source="$_pkgname-$pkgver.tar.gz::https://github.com/zopefoundation/zope.component/archive/$pkgver.tar.gz"
-builddir="$srcdir"/$_pkgname-$pkgver
-
-build() {
- python2 setup.py build
- python3 setup.py build
-}
-
-check() {
- python2 setup.py test
- python3 setup.py test
-}
-
-package() {
- mkdir -p "$pkgdir"
-}
-
-_py2() {
- replaces="$pkgname"
- depends="${depends//py-/py2-}"
- _py python2
-}
-
-_py3() {
- depends="${depends//py-/py3-}"
- _py python3
-}
-
-_py() {
- local python="$1"
- pkgdesc="$pkgdesc (for $python)"
- depends="$depends $python"
- install_if="$pkgname=$pkgver-r$pkgrel $python"
-
- cd "$builddir"
- $python setup.py install --prefix=/usr --root="$subpkgdir"
-}
-
-sha512sums="cca873bcb62b6eb60825c55fa8fe9704e505c9bec90f851921545d543c23e3995cc9d70ab9e7b8cc6b37853bbcffd09c93891f675ff113e68b56e23d8b28c912 zope.component-4.5.tar.gz"