aboutsummaryrefslogtreecommitdiffstats
path: root/community/py-zope-component
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2015-12-09 13:36:50 +0100
committerCarlo Landmeter <clandmeter@gmail.com>2015-12-09 13:36:50 +0100
commit15d1ec2d5e5d36fc7e78d96f34d9c3583bf56dc2 (patch)
treedf4c2d69dbcda1059524061bd66259f1cd4734ca /community/py-zope-component
parenta66174411f51be92d56e3937f790e1fca75c91d5 (diff)
downloadaports-15d1ec2d5e5d36fc7e78d96f34d9c3583bf56dc2.tar.bz2
aports-15d1ec2d5e5d36fc7e78d96f34d9c3583bf56dc2.tar.xz
move letsencrypt deps to community
Diffstat (limited to 'community/py-zope-component')
-rw-r--r--community/py-zope-component/APKBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/community/py-zope-component/APKBUILD b/community/py-zope-component/APKBUILD
new file mode 100644
index 0000000000..471c68f82f
--- /dev/null
+++ b/community/py-zope-component/APKBUILD
@@ -0,0 +1,41 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=py-zope-component
+_pkgname=zope.component
+pkgver=4.1.0
+pkgrel=0
+pkgdesc="Zope Component Architecture"
+url="https://pypi.python.org/pypi/zope.component"
+arch="noarch"
+license="ZPL2+"
+depends="python"
+depends_dev=""
+makedepends="python-dev py-setuptools"
+install=""
+subpackages=""
+source="http://pypi.python.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.zip"
+
+_builddir="$srcdir"/$_pkgname-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ python setup.py build || return 1
+}
+
+package() {
+ cd "$_builddir"
+ python setup.py install --prefix=/usr --root="$pkgdir" || return 1
+}
+
+md5sums="8e185893699f9fa577bd9ada0a5302fa zope.component-4.1.0.zip"
+sha256sums="6cb9eec6a735db27452b5825fb498684b5bff15bc0c26a7e1e5c9953a7588f4e zope.component-4.1.0.zip"
+sha512sums="438489717809982d7629e156e5252a689d0e6af5dc794688b270eddef47467fdac37cb32fa9a5f915a0303754a8365b4e05d61e6bad63228d7e3c63dba9263a0 zope.component-4.1.0.zip"