aboutsummaryrefslogtreecommitdiffstats
path: root/community/py2-functools32
diff options
context:
space:
mode:
authorKeith Maxwell <keith.maxwell@gmail.com>2019-04-15 14:25:03 +0100
committerNatanael Copa <ncopa@alpinelinux.org>2019-04-16 09:58:31 +0000
commit5e69e65606a215b9e1fe08a3bc49125eb2077e1c (patch)
tree0bfb5a5764f81f14813b59bf819efd06cc87a59a /community/py2-functools32
parentf0da75ed19cab19ec8d668aea36cb2938b498041 (diff)
downloadaports-5e69e65606a215b9e1fe08a3bc49125eb2077e1c.tar.bz2
aports-5e69e65606a215b9e1fe08a3bc49125eb2077e1c.tar.xz
community/py2-functools32: modernise and add check
Diffstat (limited to 'community/py2-functools32')
-rw-r--r--community/py2-functools32/APKBUILD15
1 files changed, 9 insertions, 6 deletions
diff --git a/community/py2-functools32/APKBUILD b/community/py2-functools32/APKBUILD
index f90d099699..fa8fcc2da5 100644
--- a/community/py2-functools32/APKBUILD
+++ b/community/py2-functools32/APKBUILD
@@ -4,19 +4,24 @@ pkgname=py2-functools32
_pkgname=functools32
pkgver=3.2.3
_pkgver=${pkgver}-2
-pkgrel=0
+pkgrel=1
pkgdesc="Backport of the functools module from Python 3.2.3 for use on 2.7 and PyPy."
url="https://pypi.python.org/pypi/functools32"
arch="noarch"
license="PSF"
depends="python2"
-makedepends="python2-dev py-setuptools"
-source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$_pkgver.tar.gz"
+makedepends="python2-dev py2-setuptools"
+source="https://files.pythonhosted.org/packages/source/f/$_pkgname/$_pkgname-$_pkgver.tar.gz"
builddir="$srcdir/$_pkgname-$_pkgver"
build() {
cd "$builddir"
- python2 setup.py build || return 1
+ python2 setup.py build
+}
+
+check() {
+ cd "$builddir"
+ python2 test_functools32.py
}
package() {
@@ -24,8 +29,6 @@ package() {
python2 setup.py install --prefix=/usr --root="$pkgdir"
}
-
-
md5sums="09f24ffd9af9f6cd0f63cb9f4e23d4b2 functools32-3.2.3-2.tar.gz"
sha256sums="f6253dfbe0538ad2e387bd8fdfd9293c925d63553f5813c4e587745416501e6d functools32-3.2.3-2.tar.gz"
sha512sums="ad944019f4aefde292b6872bfe06862d01920a2f44adf8740c36ed51d16d879be7638591aaddf9dac4ec83b6f05bbf81972d5f32854abedcce3dde080459f7f7 functools32-3.2.3-2.tar.gz"