aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-aiohttp1-cors
diff options
context:
space:
mode:
authorFrancesco Colista <fcolista@alpinelinux.org>2017-06-01 11:56:58 +0000
committerFrancesco Colista <fcolista@alpinelinux.org>2017-06-02 09:56:00 +0000
commit720058789985437c62f900c49f065b838bf473ac (patch)
treebdf5e0b5524ef637811e9a9099e327122cf8293a /community/py3-aiohttp1-cors
parentcbd163ecd102f0780fa729692e343ead03be773a (diff)
downloadaports-720058789985437c62f900c49f065b838bf473ac.tar.bz2
aports-720058789985437c62f900c49f065b838bf473ac.tar.xz
community/py3-aiohttp1-cors: new aport. Needed to make GNS3 works again
Diffstat (limited to 'community/py3-aiohttp1-cors')
-rw-r--r--community/py3-aiohttp1-cors/APKBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/community/py3-aiohttp1-cors/APKBUILD b/community/py3-aiohttp1-cors/APKBUILD
new file mode 100644
index 0000000000..dcd26aca1a
--- /dev/null
+++ b/community/py3-aiohttp1-cors/APKBUILD
@@ -0,0 +1,31 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=py3-aiohttp1-cors
+_pkgname=aiohttp_cors
+pkgver=0.5.3
+pkgrel=0
+pkgdesc="CORS support for aiohttp - 1.x version"
+url="https://github.com/aio-libs/aiohttp-cors"
+arch="noarch"
+license="ASL 2.0"
+depends="py3-aiohttp1 !py3-aiohttp-cors"
+makedepends="python3-dev"
+source="$_pkgname-$pkgver.tar.gz::https://github.com/aio-libs/aiohttp-cors/archive/v$pkgver.tar.gz"
+builddir="$srcdir"/aiohttp-cors-$pkgver
+
+check() {
+ cd "$builddir"
+ python3 setup.py check
+}
+
+build() {
+ cd "$builddir"
+ python3 setup.py build || return 1
+}
+
+package() {
+ cd "$builddir"
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="0813ea48de714c85e361dfdaeef1a69526f7446dcc4ce637139cd333dedea58c635f85cfad1c3ccfb0df6e573f0351f282fdbd9726211d5915ed2ba120206b09 aiohttp_cors-0.5.3.tar.gz"