aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-aiohttp
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2016-11-19 18:28:30 +0100
committerJakub Jirutka <jakub@jirutka.cz>2016-11-19 18:28:39 +0100
commit322d6515967a1c70a59f537e6003ed3aaaeeaf7f (patch)
treed62cfbf63a7814a6b3ecd652811a3d9896e176e9 /community/py3-aiohttp
parent8c4d0ef739f2bafcdea2dd9acad3325916498737 (diff)
downloadaports-322d6515967a1c70a59f537e6003ed3aaaeeaf7f.tar.bz2
aports-322d6515967a1c70a59f537e6003ed3aaaeeaf7f.tar.xz
community/py3-aiohttp: improve abuild
Diffstat (limited to 'community/py3-aiohttp')
-rw-r--r--community/py3-aiohttp/APKBUILD14
1 files changed, 6 insertions, 8 deletions
diff --git a/community/py3-aiohttp/APKBUILD b/community/py3-aiohttp/APKBUILD
index a9d1d18dd0..cda5f2fe2e 100644
--- a/community/py3-aiohttp/APKBUILD
+++ b/community/py3-aiohttp/APKBUILD
@@ -9,13 +9,11 @@ url="http://pypi.python.org/pypi/aiohttp"
arch="all"
license="ASL 2.0"
depends="python3 py3-chardet py3-multidict"
-depends_dev=""
-makedepends="$depends_dev py-setuptools python3-dev"
-install=""
+makedepends="python3-dev"
subpackages="$pkgname-dev"
-source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+source="$pkgname-$pkgver.tar.gz::https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+builddir="$srcdir/$_pkgname-$pkgver"
-builddir="$srcdir"/$_pkgname-$pkgver
build() {
cd "$builddir"
python3 setup.py build || return
@@ -26,6 +24,6 @@ package() {
python3 setup.py install --root="$pkgdir" --optimize=1 || return 1
}
-md5sums="2a096b103baa381d9ac910626f57ef2b aiohttp-1.1.4.tar.gz"
-sha256sums="11397e2dfdda688d98d9a22f822234c1f2b2071f661f4a8b261ca346e2103eaf aiohttp-1.1.4.tar.gz"
-sha512sums="d42f296a8dc7992c7de322bf4367379924df65613f602cd9d15a9458b2cbf8ff1b476d42dc947ed45ff1bf1042bcd9dfba22a14456559113ead57513f21ef69b aiohttp-1.1.4.tar.gz"
+md5sums="2a096b103baa381d9ac910626f57ef2b py3-aiohttp-1.1.4.tar.gz"
+sha256sums="11397e2dfdda688d98d9a22f822234c1f2b2071f661f4a8b261ca346e2103eaf py3-aiohttp-1.1.4.tar.gz"
+sha512sums="d42f296a8dc7992c7de322bf4367379924df65613f602cd9d15a9458b2cbf8ff1b476d42dc947ed45ff1bf1042bcd9dfba22a14456559113ead57513f21ef69b py3-aiohttp-1.1.4.tar.gz"