aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-apipkg
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-09-07 15:39:29 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-09-07 15:39:29 -0300
commitf2efab1a69bf230db190f12cb24455c59a6161cf (patch)
tree30ae6d55bf11d2f9d2e6a356a8f6a321ebdd8ef7 /community/py3-apipkg
parent90c25e85cfb23639e9125b24249928bcd6789564 (diff)
downloadaports-f2efab1a69bf230db190f12cb24455c59a6161cf.tar.bz2
aports-f2efab1a69bf230db190f12cb24455c59a6161cf.tar.xz
community/py3-apipkg: rename from py-apipkg
Diffstat (limited to 'community/py3-apipkg')
-rw-r--r--community/py3-apipkg/14.patch11
-rw-r--r--community/py3-apipkg/APKBUILD54
2 files changed, 65 insertions, 0 deletions
diff --git a/community/py3-apipkg/14.patch b/community/py3-apipkg/14.patch
new file mode 100644
index 0000000000..d2854e2e1a
--- /dev/null
+++ b/community/py3-apipkg/14.patch
@@ -0,0 +1,11 @@
+--- a/test_apipkg.py
++++ b/test_apipkg.py
+@@ -13,7 +13,7 @@
+ class TestRealModule:
+
+ def setup_class(cls):
+- cls.tmpdir = py.test.ensuretemp('test_apipkg')
++ cls.tmpdir = py.path.local('test_apipkg')
+ sys.path = [str(cls.tmpdir)] + sys.path
+ pkgdir = cls.tmpdir.ensure('realtest', dir=1)
+
diff --git a/community/py3-apipkg/APKBUILD b/community/py3-apipkg/APKBUILD
new file mode 100644
index 0000000000..5417ad9d48
--- /dev/null
+++ b/community/py3-apipkg/APKBUILD
@@ -0,0 +1,54 @@
+# Contributor: Dmitry Romanenko <dmitry@romanenko.in>
+# Maintainer: Dmitry Romanenko <dmitry@romanenko.in>
+pkgname=py-apipkg
+_pkgname=apipkg
+pkgver=1.5
+pkgrel=2
+pkgdesc="apipkg: namespace control and lazy-import mechanism"
+url="https://github.com/pytest-dev/apipkg"
+arch="noarch"
+license="MIT"
+checkdepends="pytest"
+makedepends="python2-dev python3-dev py-setuptools py-setuptools_scm"
+subpackages="py3-$_pkgname:_py3 py2-$_pkgname:_py2"
+source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz
+ 14.patch"
+builddir="$srcdir"/$_pkgname-$pkgver
+
+build() {
+ cd "$builddir"
+ python2 setup.py build
+ python3 setup.py build
+}
+
+check() {
+ cd "$builddir"
+ PYTHONPATH="$builddir/build/lib/:$PYTHONPATH" python2 -m pytest
+ PYTHONPATH="$builddir/build/lib/:$PYTHONPATH" python3 -m pytest
+}
+
+package() {
+ mkdir -p "$pkgdir"
+}
+
+_py2() {
+ replaces="$pkgname"
+ _py python2
+}
+
+_py3() {
+ _py python3
+}
+
+_py() {
+ local python="$1"
+ pkgdesc="$pkgdesc (for $python)"
+ depends="$depends $python"
+ install_if="$pkgname=$pkgver-r$pkgrel $python"
+
+ cd "$builddir"
+ $python setup.py install --prefix=/usr --root="$subpkgdir"
+}
+
+sha512sums="828937ca5e203915248fac54db8e7c13f941e006403f2a415c27fa4d1aa114790be3d7b5dd892f528611e5e6dfe75114ee80f4f4589a03c3f789ae6ddfcae0bf apipkg-1.5.tar.gz
+96181be5cbc1bac03aa74347247fd4e97a8d2b3a93ebc8d412acdb3a02ae3792193234d18b0be626be2e76108c5803bd39ae995a98ecf324b8bc0e98a72bb7a8 14.patch"