aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-argh/APKBUILD
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-09-07 22:11:44 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-09-07 22:20:32 -0300
commitcd755b7e6dd47323b05542ce1c91ada76035050d (patch)
tree7270ab6fd2862e00e643613401876295fc6fee6f /community/py3-argh/APKBUILD
parentb47f4dd9624a2fd53aa525cbd54a7b83e7177f96 (diff)
downloadaports-cd755b7e6dd47323b05542ce1c91ada76035050d.tar.bz2
aports-cd755b7e6dd47323b05542ce1c91ada76035050d.tar.xz
community/py3-argh: drop py2
Diffstat (limited to 'community/py3-argh/APKBUILD')
-rw-r--r--community/py3-argh/APKBUILD44
1 files changed, 11 insertions, 33 deletions
diff --git a/community/py3-argh/APKBUILD b/community/py3-argh/APKBUILD
index a42b406ea3..4a657dc01a 100644
--- a/community/py3-argh/APKBUILD
+++ b/community/py3-argh/APKBUILD
@@ -1,55 +1,33 @@
# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
-pkgname=py-argh
+pkgname=py3-argh
_pkgname=argh
pkgver=0.26.2
-pkgrel=3
-pkgdesc="A Python argparse wrapper"
+pkgrel=4
+pkgdesc="Python3 argparse wrapper"
+options="!check" # Requires unpackaged iocapture
url="https://github.com/neithere/argh"
arch="noarch"
license="LGPL-3.0-or-later"
-depends=""
-depends_dev=""
-makedepends="py-setuptools python2-dev python3-dev"
-install=""
-subpackages="py2-${pkgname#py-}:_py2 py3-${pkgname#py-}:_py3"
+depends="python3"
+makedepends="py3-setuptools"
+checkdepends="py3-mock py3-pytest"
source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
-
builddir="$srcdir/$_pkgname-$pkgver"
+replaces="py-argh" # Backwards compatibility
+provides="py-argh=$pkgver-r$pkgrel" # Backwards compatibility
+
build() {
- cd "$builddir"
- python2 setup.py build
python3 setup.py build
}
check() {
- cd "$builddir"
- python2 setup.py test
python3 setup.py test
}
package() {
- mkdir -p "$pkgdir"
-}
-
-_py2() {
- replaces="$pkgname"
- _py python2
-}
-
-_py3() {
- _py python3
-}
-
-_py() {
- local python="$1"
- pkgdesc="$pkgdesc (for $python)"
- depends="$depends $python"
- install_if="$pkgname=$pkgver-r$pkgrel $python"
-
- cd "$builddir"
- $python setup.py install --prefix=/usr --root="$subpkgdir"
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
}
sha512sums="90382900d5cec9629dacb4459a2c9491d1425b66fa3f90d7cbf511dec846a99dbb9424f3e08f0c006da48fbf9c067078705be70b314700541fd800630e4b1707 argh-0.26.2.tar.gz"