aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-async-timeout
diff options
context:
space:
mode:
authorFabian Affolter <fabian@affolter-engineering.ch>2016-11-07 22:39:04 +0000
committerJakub Jirutka <jakub@jirutka.cz>2016-11-09 01:54:16 +0100
commit05180d041c9ae3a2198b8a3ffc7a009dcd59c894 (patch)
tree675969e5bd7f15c7b4d1b8cdd0009a3edabe3720 /community/py3-async-timeout
parent14414e45894d93a373ddfd6efa2e5842eee570a9 (diff)
downloadaports-05180d041c9ae3a2198b8a3ffc7a009dcd59c894.tar.bz2
aports-05180d041c9ae3a2198b8a3ffc7a009dcd59c894.tar.xz
community/py3-async-timeout: new aport (dependency of py3-aiohttp)
https://pypi.python.org/pypi/async_timeout Timeout context manager for asyncio programs
Diffstat (limited to 'community/py3-async-timeout')
-rw-r--r--community/py3-async-timeout/APKBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/community/py3-async-timeout/APKBUILD b/community/py3-async-timeout/APKBUILD
new file mode 100644
index 0000000000..fc22fd938a
--- /dev/null
+++ b/community/py3-async-timeout/APKBUILD
@@ -0,0 +1,28 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=py3-async-timeout
+_pkgname=async-timeout
+pkgver=1.1.0
+pkgrel=0
+pkgdesc="Timeout context manager for asyncio programs"
+url="https://pypi.python.org/pypi/async_timeout"
+arch="noarch"
+license="ASL 2.0"
+depends="python3"
+makedepends="python3-dev"
+source="$pkgname-$pkgver.tar.gz::https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+builddir="$srcdir/$_pkgname-$pkgver"
+
+build() {
+ cd "$builddir"
+ python3 setup.py build
+}
+
+package() {
+ cd "$builddir"
+ python3 setup.py install --root="$pkgdir"
+}
+
+md5sums="8c3565e165266dd7710a76f50ae44319 py3-async-timeout-1.1.0.tar.gz"
+sha256sums="b88bd1fe001b800ec23c7bf27a81b32819e2a56668e9fba5646a7f3618143081 py3-async-timeout-1.1.0.tar.gz"
+sha512sums="7132b0616052623c17d7a541051f3e759f8dc87f9ff1730585a1010bc6e139c24d5b8835431749d695fde56fb465f22094ec3f98f5f95b0b7664ec9e1f990cac py3-async-timeout-1.1.0.tar.gz"