aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-atspi/APKBUILD
diff options
context:
space:
mode:
authorRasmus Thomsen <oss@cogitri.dev>2019-09-23 01:28:43 +0200
committerRasmus Thomsen <oss@cogitri.dev>2019-09-23 01:29:48 +0200
commitdfbe0e46948cbfbffec48c6089fc3a85db042c14 (patch)
treecc1e94dc2126ac0636294396cb9e60ac520f4a55 /community/py3-atspi/APKBUILD
parenteeb67c19c8984d0d72d6207c392408db9b46cddd (diff)
downloadaports-dfbe0e46948cbfbffec48c6089fc3a85db042c14.tar.bz2
aports-dfbe0e46948cbfbffec48c6089fc3a85db042c14.tar.xz
community/py3-atspi: move from testing
Diffstat (limited to 'community/py3-atspi/APKBUILD')
-rw-r--r--community/py3-atspi/APKBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/community/py3-atspi/APKBUILD b/community/py3-atspi/APKBUILD
new file mode 100644
index 0000000000..544fddf03c
--- /dev/null
+++ b/community/py3-atspi/APKBUILD
@@ -0,0 +1,31 @@
+# Contributor: Rasmus Thomsen <oss@cogitri.dev>
+# Maintainer: Rasmus Thomsen <oss@cogitri.dev>
+pkgname=py3-atspi
+pkgver=2.34.0
+pkgrel=0
+pkgdesc="Python client bindings for D-Bus AT-SPI"
+url="https://www.freedesktop.org/wiki/Accessibility/AT-SPI2/"
+arch="noarch"
+license="GPL-2.0-or-later"
+depends="python3 py-gobject3"
+makedepends="python3-dev py-gobject3-dev"
+options="!check" # Don't work with python3
+source="https://download.gnome.org/sources/pyatspi/${pkgver%.*}/pyatspi-$pkgver.tar.xz"
+builddir="$srcdir/pyatspi-$pkgver"
+
+build() {
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --localstatedir=/var
+ make
+}
+
+package() {
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="61b157f067e23b7a964cf8268f556ad059982f448e436ecb25c96915ecb53918c6ab7b29bfb4e7b85e25e6038e27678fbd3d0bfb61d14a038ab5eaeee1f682b4 pyatspi-2.34.0.tar.xz"