aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-automat/APKBUILD
diff options
context:
space:
mode:
authorprspkt <prspkt@protonmail.com>2019-06-25 13:38:35 +0300
committerprspkt <prspkt@protonmail.com>2019-06-25 13:38:35 +0300
commit070521dd0131105755a0d599b0a2efe5ccb77af8 (patch)
tree3ef1f1edb9e6be3e100a3b8eaffa5f05d1d7a74f /community/py3-automat/APKBUILD
parent920ac00f32a10e7e77e305ce2bc360b2fba1d58a (diff)
downloadaports-070521dd0131105755a0d599b0a2efe5ccb77af8.tar.bz2
aports-070521dd0131105755a0d599b0a2efe5ccb77af8.tar.xz
community/py3-automat: move from testing
Diffstat (limited to 'community/py3-automat/APKBUILD')
-rw-r--r--community/py3-automat/APKBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/community/py3-automat/APKBUILD b/community/py3-automat/APKBUILD
new file mode 100644
index 0000000000..82f8e049b7
--- /dev/null
+++ b/community/py3-automat/APKBUILD
@@ -0,0 +1,31 @@
+# Contributor: Leo <thinkabit.ukim@gmail.com>
+# Contributor: Tiago Ilieve <tiago.myhro@gmail.com>
+# Maintainer: Tiago Ilieve <tiago.myhro@gmail.com>
+pkgname=py3-automat
+_pkgname=Automat
+pkgver=0.7.0
+pkgrel=2
+pkgdesc="Self-service finite-state machines for the programmer on the go"
+url="https://automat.readthedocs.io/"
+arch="noarch"
+license="MIT"
+depends="py3-attrs py3-six"
+makedepends="py3-setuptools py3-incremental pytest py3-graphviz py3-twisted"
+source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+builddir="$srcdir/$_pkgname-$pkgver"
+
+replaces="py-automat" # Backwards compatibility
+provides="py-automat=$pkver-r$pkgrel" # Backwards compatibility
+
+build() {
+ python3 setup.py build
+}
+
+check() {
+ py.test-3 automat/_test
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+sha512sums="a6f307d312a3ceb721071b5212297c73d2306894b5fafd39265578041a2859bd6f041ac43a654bdda4175a70a4e90e0db1ee35cd43fa620cd5c594b5d1988a74 Automat-0.7.0.tar.gz"