aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-backcall/APKBUILD
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-09-08 21:30:57 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-09-08 21:30:57 -0300
commit49d8451d2378c3db008332f158bcbc66cb580eea (patch)
tree4468e3ae6b7d57db65b7fa9555ecec42a96e7266 /community/py3-backcall/APKBUILD
parentb11b0d4ac24b0b69c24578bd3544c30e63459982 (diff)
downloadaports-49d8451d2378c3db008332f158bcbc66cb580eea.tar.bz2
aports-49d8451d2378c3db008332f158bcbc66cb580eea.tar.xz
community/py3-backcall: fix provides, makedepends and checkdepends
Diffstat (limited to 'community/py3-backcall/APKBUILD')
-rw-r--r--community/py3-backcall/APKBUILD11
1 files changed, 6 insertions, 5 deletions
diff --git a/community/py3-backcall/APKBUILD b/community/py3-backcall/APKBUILD
index f3ee47ea73..353e627204 100644
--- a/community/py3-backcall/APKBUILD
+++ b/community/py3-backcall/APKBUILD
@@ -2,17 +2,18 @@
# Maintainer: Kevin Daudt <kdaudt@alpinelinux.org>
pkgname=py3-backcall
pkgver=0.1.0
-pkgrel=1
+pkgrel=2
pkgdesc="Backwards compatible callback APIs"
url="https://github.com/takluyver/backcall"
arch="noarch"
license="BSD-3-Clause"
-makedepends="python3-dev"
-checkdepends="pytest"
+makedepends="py3-setuptools"
+checkdepends="py3-pytest"
source="https://files.pythonhosted.org/packages/source/b/backcall/backcall-$pkgver.tar.gz"
builddir="$srcdir/${pkgname#py3-}-$pkgver"
-replaces="py-backcall"
-provides="py-backcall"
+
+replaces="py-backcall" # Backwards compatibility
+provides="py-backcall=$pkgver-r$pkgrel" # Backwards compatibility
build() {
python3 setup.py build