aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-beautifulsoup4
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-08-28 23:42:25 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-08-29 02:17:07 -0300
commit6ec90974720214a103eccd411d1cb4b62a7514bd (patch)
treee4b0b7b12ccc8b5d6dd59a907e0086baa08b1bc3 /community/py3-beautifulsoup4
parent220a5e824dc44dcd5f68fa191c2ae78b3f5cce19 (diff)
downloadaports-6ec90974720214a103eccd411d1cb4b62a7514bd.tar.bz2
aports-6ec90974720214a103eccd411d1cb4b62a7514bd.tar.xz
community/py3-beautifulsoup4: upgrade to 4.8.0
Diffstat (limited to 'community/py3-beautifulsoup4')
-rw-r--r--community/py3-beautifulsoup4/APKBUILD58
1 files changed, 13 insertions, 45 deletions
diff --git a/community/py3-beautifulsoup4/APKBUILD b/community/py3-beautifulsoup4/APKBUILD
index caf16d42a3..4461173bc2 100644
--- a/community/py3-beautifulsoup4/APKBUILD
+++ b/community/py3-beautifulsoup4/APKBUILD
@@ -1,64 +1,32 @@
# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
-pkgname=py-beautifulsoup4
+pkgname=py3-beautifulsoup4
_pkgname=beautifulsoup4
-pkgver=4.6.1
-pkgrel=1
+pkgver=4.8.0
+pkgrel=0
pkgdesc="A Python HTML/XML parser"
url="http://www.crummy.com/software/BeautifulSoup/index.html"
arch="noarch"
license="MIT"
-makedepends="python2-dev py-setuptools python3-dev"
-subpackages="py3-$_pkgname:_py3 py2-$_pkgname:_py2"
-source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+depends="python3 py3-soupsieve"
+makedepends="py3-setuptools"
+source="https://files.pythonhosted.org/packages/source/b/beautifulsoup4/beautifulsoup4-$pkgver.tar.gz"
builddir="$srcdir/$_pkgname-$pkgver"
-prepare() {
- default_prepare
-
- local python; for python in python2 python3; do
- cp -r "$builddir" "$builddir-$python"
- done
-
- cd "$builddir-python3"
- 2to3 -w bs4 >/dev/null
-}
+replaces="py-beautifulsoup4" # Backwards compatibility
+provides="py-beautifulsoup4=$pkgver-r$pkgrel" # Backwards compatibility
build() {
- local python; for python in python2 python3; do
- cd "$builddir-$python"
- $python setup.py build
- done
+ 2to3 -w bs4
+ python3 setup.py build
}
check() {
- local python; for python in python2 python3; do
- cd "$builddir-$python"
- $python -c "import bs4"
- done
+ python3 -m unittest discover -s bs4
}
package() {
- mkdir -p "$pkgdir"
-}
-
-_py2() {
- replaces="$pkgname"
- _py python2
-}
-
-_py3() {
- _py python3
-}
-
-_py() {
- local python="$1"
- pkgdesc="$pkgdesc (for $python)"
- depends="$python"
- install_if="$pkgname=$pkgver-r$pkgrel $python"
-
- cd "$builddir-$python"
- $python setup.py install --prefix=/usr --root="$subpkgdir"
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
}
-sha512sums="598f6be620d6c656bdab6d0d6e767a1ffc695a790dc5e3e8cc0f411555de1c52ef1972c93d0916135375c74e5272dd112f00e5ed2fb12a12c90d5d30d852e91c beautifulsoup4-4.6.1.tar.gz"
+sha512sums="00e157f8031dbb0e30e49158ca30f9e9207647dd3355edf23c2906b9d0c8b93250669edf5b20372e62546501a0cd2d7e87b793faf30bc122b5544f9358c1a4db beautifulsoup4-4.8.0.tar.gz"