aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-bleach/APKBUILD
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-12-06 21:00:20 +0100
committerLeo <thinkabit.ukim@gmail.com>2019-12-06 21:00:20 +0100
commitd3853b6ee802eaf934201fa7c6a6828a0507fd62 (patch)
tree6f45b47ba77d99c5b9c74a1c158fe3004b87e727 /community/py3-bleach/APKBUILD
parent4690de7d722481f46369aeae11ee216ed151378e (diff)
downloadaports-d3853b6ee802eaf934201fa7c6a6828a0507fd62.tar.bz2
aports-d3853b6ee802eaf934201fa7c6a6828a0507fd62.tar.xz
community/py3-bleach: move from testing
Diffstat (limited to 'community/py3-bleach/APKBUILD')
-rw-r--r--community/py3-bleach/APKBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/community/py3-bleach/APKBUILD b/community/py3-bleach/APKBUILD
new file mode 100644
index 0000000000..9313ba6e4c
--- /dev/null
+++ b/community/py3-bleach/APKBUILD
@@ -0,0 +1,28 @@
+# Contributor: Leo <thinkabit.ukim@gmail.com>
+# Maintainer: Leo <thinkabit.ukim@gmail.com>
+pkgname=py3-bleach
+pkgver=3.1.0
+pkgrel=1
+pkgdesc="whitelist-based HTML sanitizing library"
+url="https://github.com/mozilla/bleach"
+arch="noarch"
+license="Apache-2.0"
+depends="python3 py3-six py3-webencodings"
+makedepends="py3-setuptools"
+checkdepends="py3-pytest"
+source="$pkgname-$pkgver.tar.gz::https://github.com/mozilla/bleach/archive/v$pkgver.tar.gz"
+builddir="$srcdir/bleach-$pkgver"
+
+build() {
+ python3 setup.py build
+}
+
+check() {
+ python3 setup.py test
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="125e22c27e7064702db3c72f7f9b59caf919d4eedc65111c0a901af22530416595406859d741621d4d6a52234929b820b87204f71f0e07bb46683e677140fed8 py3-bleach-3.1.0.tar.gz"