aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-boltons
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-12-06 21:00:47 +0100
committerLeo <thinkabit.ukim@gmail.com>2019-12-06 21:00:47 +0100
commita9819daf1b19e943648880deeb39219e970b9e64 (patch)
tree51d0f791d893e72a33f8d91edbd334f7e1b6b9be /community/py3-boltons
parentec41e536b7a9319c330a9b0f0b34b0431de83c33 (diff)
downloadaports-a9819daf1b19e943648880deeb39219e970b9e64.tar.bz2
aports-a9819daf1b19e943648880deeb39219e970b9e64.tar.xz
community/py3-boltons: move from testing
Diffstat (limited to 'community/py3-boltons')
-rw-r--r--community/py3-boltons/APKBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/community/py3-boltons/APKBUILD b/community/py3-boltons/APKBUILD
new file mode 100644
index 0000000000..5421b4b1fe
--- /dev/null
+++ b/community/py3-boltons/APKBUILD
@@ -0,0 +1,28 @@
+# Contributor: Leo <thinkabit.ukim@gmail.com>
+# Maintainer: Leo <thinkabit.ukim@gmail.com>
+pkgname=py3-boltons
+pkgver=19.3.0
+pkgrel=0
+pkgdesc="Bolted-on functionality for python3"
+url="https://github.com/mahmoud/boltons"
+arch="all"
+license="BSD-3-Clause"
+depends="python3"
+makedepends="py3-setuptools"
+checkdepends="py3-pytest py3-pytest-cov"
+source="$pkgname-$pkgver.tar.gz::https://github.com/mahmoud/boltons/archive/$pkgver.tar.gz"
+builddir="$srcdir/boltons-$pkgver"
+
+build() {
+ python3 setup.py build
+}
+
+check() {
+ python3 setup.py test
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="531805de8e2a7c7c1eb2f251a2e296cb77d88e966e51cac68acaf2f408f40772be4dd85b3c36e27f2a962fccec4f6952fa82fe76908f9bbcf43f5e1cbd91f82a py3-boltons-19.3.0.tar.gz"