aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-cached-property
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@alpinelinux.org>2019-07-23 09:46:56 +0000
committerCarlo Landmeter <clandmeter@alpinelinux.org>2019-07-23 09:47:14 +0000
commit7368d9cdcb7492dd2471991c2598ec01342534fd (patch)
tree59dafc6fc54d45a4f4db29999f8acc4b526005e5 /community/py3-cached-property
parent66802999dcfe04fd84981b91756f48cc7715e085 (diff)
downloadaports-7368d9cdcb7492dd2471991c2598ec01342534fd.tar.bz2
aports-7368d9cdcb7492dd2471991c2598ec01342534fd.tar.xz
testing/py3-cached-property: move to community
due to docker-compose
Diffstat (limited to 'community/py3-cached-property')
-rw-r--r--community/py3-cached-property/APKBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/community/py3-cached-property/APKBUILD b/community/py3-cached-property/APKBUILD
new file mode 100644
index 0000000000..c5efaa09cd
--- /dev/null
+++ b/community/py3-cached-property/APKBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=py3-cached-property
+pkgver=1.4.3
+pkgrel=1
+pkgdesc="Decorator for caching properties in classes"
+url="https://github.com/pydanny/cached-property"
+arch="noarch"
+license="BSD-3-Clause"
+depends="python3"
+makedepends="python3-dev"
+source="https://pypi.io/packages/source/c/cached-property/cached-property-$pkgver.tar.gz"
+builddir="$srcdir/cached-property-$pkgver"
+
+build() {
+ cd "$builddir"
+ python3 setup.py build
+}
+
+check() {
+ cd "$builddir"
+ python3 setup.py check
+}
+
+package() {
+ cd "$builddir"
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="e36e61af8f68a253573efbac666abd4e897142b3cec2499c50ba932924f8dad786979e1a297df7f0898310ae1aec1116615dff6e39c0b203e262628b450ad91f cached-property-1.4.3.tar.gz"