aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-cachetools
diff options
context:
space:
mode:
authorKeith Maxwell <keith.maxwell@gmail.com>2019-05-12 15:21:44 +0100
committerprspkt <prspkt@protonmail.com>2019-06-21 02:06:05 +0300
commitdc538e7917e64404a1bec06c75f6f58804cbe1ea (patch)
treebe96f715a65c1057d4b283eb65339681d156f9cf /community/py3-cachetools
parentfbba1fbd764fe8e8b33f75438d987c883c3ea5a7 (diff)
downloadaports-dc538e7917e64404a1bec06c75f6f58804cbe1ea.tar.bz2
aports-dc538e7917e64404a1bec06c75f6f58804cbe1ea.tar.xz
community/py3-cachetools: move from testing
Diffstat (limited to 'community/py3-cachetools')
-rw-r--r--community/py3-cachetools/APKBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/community/py3-cachetools/APKBUILD b/community/py3-cachetools/APKBUILD
new file mode 100644
index 0000000000..25b05397c5
--- /dev/null
+++ b/community/py3-cachetools/APKBUILD
@@ -0,0 +1,32 @@
+# Contributor: Jakub Jirutka <jakub@jirutka.cz>
+# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
+pkgname=py3-cachetools
+_pkgname=cachetools
+pkgver=2.1.0
+pkgrel=1
+pkgdesc="Extensible memoizing collections and decorators"
+url="https://github.com/tkem/cachetools"
+arch="noarch"
+license="MIT"
+depends="python3"
+checkdepends="py3-pytest"
+makedepends="python3-dev"
+source="$pkgname-$pkgver.tar.gz::https://github.com/tkem/cachetools/archive/v$pkgver.tar.gz"
+builddir="$srcdir/$_pkgname-$pkgver"
+
+build() {
+ cd "$builddir"
+ python3 setup.py build
+}
+
+check() {
+ cd "$builddir"
+ python3 -m pytest .
+}
+
+package() {
+ cd "$builddir"
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="359f0b57c34af96d4c8cfac19daa591e357db19c592ce89449001593f3044affb6e6109e1d2b63666dd8c95c6c496387032759d2ef01e5d5ae93eef39df15d72 py3-cachetools-2.1.0.tar.gz"