aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-characteristic
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-09-08 07:05:23 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-09-08 07:05:23 -0300
commit4e08063a7e87b7034ad05162c1a612ddcf2b817e (patch)
tree2fccd666ecc892cf7363deadb0b8b363e94a67c3 /community/py3-characteristic
parent4d6ea2ca42e7964dc5eb85703e45b2d3853eecf7 (diff)
downloadaports-4e08063a7e87b7034ad05162c1a612ddcf2b817e.tar.bz2
aports-4e08063a7e87b7034ad05162c1a612ddcf2b817e.tar.xz
community/py3-characteristic: drop py2
Diffstat (limited to 'community/py3-characteristic')
-rw-r--r--community/py3-characteristic/APKBUILD46
1 files changed, 18 insertions, 28 deletions
diff --git a/community/py3-characteristic/APKBUILD b/community/py3-characteristic/APKBUILD
index 8a9fd6a395..dddc7e365f 100644
--- a/community/py3-characteristic/APKBUILD
+++ b/community/py3-characteristic/APKBUILD
@@ -1,49 +1,39 @@
# Contributor: Francesco Colista <fcolista@alpinelinux.org>
# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
-pkgname=py-characteristic
+pkgname=py3-characteristic
_pkgname=characteristic
pkgver=14.3.0
-pkgrel=4
+pkgrel=5
pkgdesc="Service identity verification for pyOpenSSL"
-url="https://pypi.python.org/pypi/characteristic"
+url="https://characteristic.readthedocs.io/en/stable/"
arch="noarch"
license="MIT"
-depends=""
-makedepends="py-setuptools py2-pytest python2-dev py3-pytest python3-dev"
-install=""
-subpackages="py3-${pkgname/py-/}:_py3 py2-${pkgname/py-/}:_py2"
+depends="python3"
+makedepends="py3-setuptools"
+checkdepends="py3-pytest"
source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
-
builddir="$srcdir"/$_pkgname-$pkgver
-build() {
- cd "$builddir"
- python2 setup.py build || return 1
- python3 setup.py build || return 1
-}
+replaces="py-characteristic" # Backwards compatibility
+provides="py-characteristic=$pkgver-r$pkgrel" # Backwards compatibility
-package() {
- mkdir -p "$pkgdir"
+prepare() {
+ default_prepare
+ # having only [pytest] errors out
+ sed -i 's|pytest|tool:pytest|' setup.cfg
}
-_py() {
- local python=$1
- pkgdesc="$pkgdesc - $python"
- install_if="$pkgname=$pkgver-r$pkgrel $python"
- cd "$builddir"
- $python setup.py install --prefix=/usr --root="$subpkgdir"
+build() {
+ python3 setup.py build
}
-_py2() {
- _py python2
- replaces="$pkgname"
+check() {
+ py.test-3
}
-_py3() {
- _py python3
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
}
-md5sums="b249368dd021fde1c06b4802867c0913 characteristic-14.3.0.tar.gz"
-sha256sums="ded68d4e424115ed44e5c83c2a901a0b6157a959079d7591d92106ffd3ada380 characteristic-14.3.0.tar.gz"
sha512sums="e13a86f453cd3688a74188005b82a661a9c73d9f0408d9afe9e0575e69ffe87a5327f51e2c16a9c0a653b738e7c014d5aa08e353835f0aca7897714b7ae56e83 characteristic-14.3.0.tar.gz"