aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-cheetah/APKBUILD
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-09-11 22:08:54 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-09-12 18:45:49 -0300
commit7c60da7ecaa9d6b7d2c9d9979ef5b285fe4906e8 (patch)
tree7f0dc1b04733437cbe607d0d9ab2329d2d7bad8c /community/py3-cheetah/APKBUILD
parent534c7a0ff2119387ecce7ca366e56a81955c88b6 (diff)
downloadaports-7c60da7ecaa9d6b7d2c9d9979ef5b285fe4906e8.tar.bz2
aports-7c60da7ecaa9d6b7d2c9d9979ef5b285fe4906e8.tar.xz
community/py3-cheetah: drop py2
Diffstat (limited to 'community/py3-cheetah/APKBUILD')
-rw-r--r--community/py3-cheetah/APKBUILD38
1 files changed, 8 insertions, 30 deletions
diff --git a/community/py3-cheetah/APKBUILD b/community/py3-cheetah/APKBUILD
index 7acf1db394..6c7936e030 100644
--- a/community/py3-cheetah/APKBUILD
+++ b/community/py3-cheetah/APKBUILD
@@ -1,53 +1,31 @@
# Contributor: Matt Dainty <matt+alpine@bodgit-n-scarper.com>
# Maintainer: TBK <alpine@jjtc.eu>
-pkgname=py-cheetah
-_pkgreal=${pkgname#py-}
+pkgname=py3-cheetah
_pkgname=Cheetah3
pkgver=3.2.3
-pkgrel=0
+pkgrel=1
pkgdesc="Cheetah is a template engine and code generation tool"
url="http://www.cheetahtemplate.org/"
arch="all"
license="MIT"
-makedepends="python2-dev python3-dev py-setuptools py3-setuptools"
-subpackages="py3-$_pkgreal:_py3 py2-$_pkgreal:_py2"
+depends="python3"
+makedepends="python3-dev py3-setuptools"
source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
builddir="$srcdir"/$_pkgname-$pkgver
+replaces="py-cheetah" # Backwards compatibility
+provides="py-cheetah=$pkgver-r$pkgrel" # Backwards compatibility
+
build() {
- python2 setup.py build
python3 setup.py build
}
check() {
- python2 setup.py check
python3 setup.py check
}
-
package() {
- mkdir -p "$pkgdir"
-}
-
-_py2() {
- replaces="$pkgname"
- depends="${depends//py-/py2-}"
- _py python2
-}
-
-_py3() {
- depends="${depends//py-/py3-}"
- _py python3
-}
-
-_py() {
- local python="$1"
- pkgdesc="$pkgdesc (for $python)"
- depends="$depends $python"
- install_if="$pkgname=$pkgver-r$pkgrel $python"
-
- cd "$builddir"
- $python setup.py install --prefix=/usr --root="$subpkgdir"
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
}
sha512sums="ebc735b59d61912679405469f9d509fc73bbdde51c414320994421849f4a02266d2c286c0f618cab2a592ab47ac0a4be9ec444fab75145a0c31dd0c3c39fc1e3 Cheetah3-3.2.3.tar.gz"