aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-compreffor
diff options
context:
space:
mode:
authorRasmus Thomsen <oss@cogitri.dev>2020-01-04 18:10:34 +0100
committerRasmus Thomsen <oss@cogitri.dev>2020-01-04 22:29:55 +0100
commit3eafcc206d8fd36450de1d9943e8aaec181ca162 (patch)
tree127bc12c3d25d3e273968d4ceb5363b0e4621607 /community/py3-compreffor
parent1558b50f4ddd48696d5c2f93bbe8ee0d057c7059 (diff)
downloadaports-3eafcc206d8fd36450de1d9943e8aaec181ca162.tar.bz2
aports-3eafcc206d8fd36450de1d9943e8aaec181ca162.tar.xz
community/py3-compreffor: move from testing
Diffstat (limited to 'community/py3-compreffor')
-rw-r--r--community/py3-compreffor/APKBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/community/py3-compreffor/APKBUILD b/community/py3-compreffor/APKBUILD
new file mode 100644
index 0000000000..9384f2bd45
--- /dev/null
+++ b/community/py3-compreffor/APKBUILD
@@ -0,0 +1,28 @@
+# Contributor: Leo <thinkabit.ukim@gmail.com>
+# Maintainer: Leo <thinkabit.ukim@gmail.com>
+pkgname=py3-compreffor
+pkgver=0.5.0
+pkgrel=0
+pkgdesc="CFF table subroutinizer for FontTools"
+url="https://github.com/googlefonts/compreffor"
+arch="all"
+license="Apache-2.0"
+depends="python3 py3-fonttools"
+makedepends="py3-setuptools py3-pytest cython python3-dev"
+source="$pkgname-$pkgver.tar.gz::https://github.com/googlefonts/compreffor/archive/$pkgver.tar.gz"
+builddir="$srcdir/compreffor-$pkgver"
+
+build() {
+ python3 setup.py build
+}
+
+check() {
+ python3 setup.py test
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+ rm -rf "$pkgdir"/usr/lib/python3*/site-packages/compreffor/test
+}
+
+sha512sums="52ea65d65424ac3c8d2ae1637b740fec0bb4cc131a5a0f99ccffc6055f10c5a0e0b26fc50f29ed388050eb86f77f7b90f79ac2d46c376de13b997e8b69b3465a py3-compreffor-0.5.0.tar.gz"