aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-configshell
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-09-26 15:32:28 -0300
committerKevin Daudt <kdaudt@alpinelinux.org>2019-09-27 19:10:10 +0000
commit78ccc0c8c955f00de53ba262061fba2ff6da676d (patch)
treed97c0bfb085be3fe2267e25ed9b65f1029c8d54c /community/py3-configshell
parentd42419778b3d685abd0e062fea66787a38fbf565 (diff)
downloadaports-78ccc0c8c955f00de53ba262061fba2ff6da676d.tar.bz2
aports-78ccc0c8c955f00de53ba262061fba2ff6da676d.tar.xz
community/py3-configshell: move from main
Closes !154
Diffstat (limited to 'community/py3-configshell')
-rw-r--r--community/py3-configshell/APKBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/community/py3-configshell/APKBUILD b/community/py3-configshell/APKBUILD
new file mode 100644
index 0000000000..d747f5ba56
--- /dev/null
+++ b/community/py3-configshell/APKBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Leonardo Arena <rnalrd@alpinelinux.org>
+pkgname=py3-configshell
+_pkgname=configshell
+pkgver=1.1.26
+pkgrel=0
+pkgdesc="Python library that provides a framework for building simple but nice CLI-based applications"
+url="https://github.com/agrover/configshell-fb"
+arch="noarch"
+license="Apache-2.0"
+depends="python3 py3-six py3-urwid py3-parsing"
+makedepends="py3-setuptools"
+options="!check" # no test suite
+source="$_pkgname-fb-$pkgver.tar.gz::https://github.com/agrover/configshell-fb/archive/v$pkgver.tar.gz"
+builddir="$srcdir"/$_pkgname-fb-$pkgver
+
+build() {
+ cd "$builddir"
+ python3 setup.py build
+}
+
+package() {
+ cd "$builddir"
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="25e5b4ee812a51c99eed4d039ac8bab883218a674ff27f9eee4604d133b592574f4829ead9cb1aba4d2aca873f5414ad4ca55979c6d4eadaa9a802b1d563494d configshell-fb-1.1.26.tar.gz"