aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-crcmod
diff options
context:
space:
mode:
authorprspkt <prspkt@protonmail.com>2019-07-25 15:37:50 +0300
committerprspkt <prspkt@protonmail.com>2019-07-25 15:39:33 +0300
commitb188ee0a029a7e65dff2e8049bc8dafb5456fec5 (patch)
tree5d3a9bd7aae4cc23a30e72ff65383b9ec25ec013 /community/py3-crcmod
parent51c29b3b2b43563db0f18450b1eddb5d0e824f53 (diff)
downloadaports-b188ee0a029a7e65dff2e8049bc8dafb5456fec5.tar.bz2
aports-b188ee0a029a7e65dff2e8049bc8dafb5456fec5.tar.xz
community/py3-crcmod: drop python2
* Run test suite. Signed-off-by: prspkt <prspkt@protonmail.com>
Diffstat (limited to 'community/py3-crcmod')
-rw-r--r--community/py3-crcmod/APKBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/community/py3-crcmod/APKBUILD b/community/py3-crcmod/APKBUILD
new file mode 100644
index 0000000000..631f2a19a0
--- /dev/null
+++ b/community/py3-crcmod/APKBUILD
@@ -0,0 +1,32 @@
+# Contributor: Stuart Cardall <developer@it-offshore.co.uk>
+# Maintainer: Stuart Cardall <developer@it-offshore.co.uk>
+pkgname=py3-crcmod
+_pkgname=crcmod
+pkgver=1.7
+pkgrel=3
+pkgdesc="Cyclic Redundancy Check (CRC) implementation in Python"
+url="https://pypi.python.org/pypi/crcmod/"
+arch="all"
+license="MIT"
+depends="python3"
+makedepends="python3-dev py3-setuptools"
+source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+builddir="$srcdir"/$_pkgname-$pkgver
+
+replaces=py-crcmod # Backwards compatibility
+provides=py-crcmod=$pkgver-r$pkgrel # Backwards compatibility
+
+build() {
+ python3 setup.py build
+}
+
+check() {
+ cd "$builddir"/python3
+ python3 -m crcmod.test
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir" --optimize=1
+}
+
+sha512sums="3c2f65004761c84f19d6ba95a0af74512108bad5007d9e20f8e684822e4196ce17073e58b47d2fa997e058e3d82782f3393458b6f0e86935418f38877d319a31 crcmod-1.7.tar.gz"