aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-daemonize
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-12-06 21:00:04 +0100
committerLeo <thinkabit.ukim@gmail.com>2019-12-06 21:00:04 +0100
commit562c32533a7d52eddb405e254b98516cebfd020e (patch)
tree44a728f8c082797c7ebcf79e1a3943a618f0829b /community/py3-daemonize
parent0500a4277a5b4ec50a32d6e95cdf22a4cb6c9e23 (diff)
downloadaports-562c32533a7d52eddb405e254b98516cebfd020e.tar.bz2
aports-562c32533a7d52eddb405e254b98516cebfd020e.tar.xz
community/py3-daemonize: move from testing
Diffstat (limited to 'community/py3-daemonize')
-rw-r--r--community/py3-daemonize/APKBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/community/py3-daemonize/APKBUILD b/community/py3-daemonize/APKBUILD
new file mode 100644
index 0000000000..a7775a6ced
--- /dev/null
+++ b/community/py3-daemonize/APKBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Luca Weiss <luca@z3ntu.xyz>
+pkgname=py3-daemonize
+_pkgname=daemonize
+pkgver=2.5.0
+pkgrel=2
+pkgdesc="Library for writing system daemons in Python"
+url="https://github.com/thesharp/daemonize"
+arch="noarch"
+license="MIT"
+depends="python3"
+makedepends="py3-setuptools"
+source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+options="!check" # No testsuite
+builddir="$srcdir/$_pkgname-$pkgver"
+
+replaces=py-daemonize # Backwards compatibility
+provides=py-daemonize=$pkgver-r$pkgrel # Backwards compatibility
+
+build() {
+ python3 setup.py build
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="5043db681b36028e3168cd2ad86235e0962bbdc46ded2f631ab36846083b0817524cddd7a9333997a82b4888b2490391bac2e1cfd043c1ddc129da54d2cbd6bd daemonize-2.5.0.tar.gz"