aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-decorator
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-09-08 07:09:05 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-09-08 10:11:13 -0300
commitd63e0479bafb534444d711e8d8891ef173677fed (patch)
treedc3864275a5d609fe3b726986bc4ba2b398c0225 /community/py3-decorator
parent0b350b3da2e8f10e3b0d0cead76c70ef6f77f11d (diff)
downloadaports-d63e0479bafb534444d711e8d8891ef173677fed.tar.bz2
aports-d63e0479bafb534444d711e8d8891ef173677fed.tar.xz
community/py3-decorator: rename from py-decorator
Diffstat (limited to 'community/py3-decorator')
-rw-r--r--community/py3-decorator/APKBUILD53
1 files changed, 53 insertions, 0 deletions
diff --git a/community/py3-decorator/APKBUILD b/community/py3-decorator/APKBUILD
new file mode 100644
index 0000000000..4af1e73113
--- /dev/null
+++ b/community/py3-decorator/APKBUILD
@@ -0,0 +1,53 @@
+# Contributor: Carlo Landmeter <clandmeter@gmail.com>
+# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
+pkgname=py-decorator
+_pkgname=decorator
+pkgver=4.4.0
+pkgrel=1
+pkgdesc="Python Decorator module"
+url="https://pypi.python.org/pypi/decorator"
+arch="noarch"
+license="BSD-2-Clause"
+depends=""
+makedepends="python2-dev py-setuptools python3-dev"
+subpackages="py3-${pkgname#py-}:_py3 py2-${pkgname#py-}:_py2"
+source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+builddir="$srcdir/$_pkgname-$pkgver"
+
+check() {
+ cd "$builddir"
+ python2 setup.py check
+ python3 setup.py check
+}
+
+
+build() {
+ cd "$builddir"
+ python2 setup.py build
+ python3 setup.py build
+}
+
+package() {
+ mkdir -p "$pkgdir"
+}
+
+_py() {
+ local python="$1"
+ pkgdesc="$pkgdesc (for $python)"
+ depends="$depends $python"
+ install_if="$pkgname=$pkgver-r$pkgrel $python"
+
+ cd "$builddir"
+ $python setup.py install --prefix=/usr --root="$subpkgdir"
+}
+
+_py2() {
+ replaces="$pkgname"
+ _py python2
+}
+
+_py3() {
+ _py python3
+}
+
+sha512sums="32c35c80581cb7fd0b2461d21c7eb14190294b2ccc9f92749b6bc74449f7d02a26281e9a2817f6f16871a6cddb7b02b8fae8119c22256fe43a6aaa31a7599dd5 decorator-4.4.0.tar.gz"