aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-distro
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-09-13 09:36:48 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-09-13 09:36:48 -0300
commit22ad8b0aa20769bc5081519014def2682794b4fb (patch)
tree996bc150a504d1e3a916e9a6ce7a38ebf366b819 /community/py3-distro
parent8471681ac5d958fa45c1c47aedbb31a1658eb364 (diff)
downloadaports-22ad8b0aa20769bc5081519014def2682794b4fb.tar.bz2
aports-22ad8b0aa20769bc5081519014def2682794b4fb.tar.xz
community/py3-distro: move from testing
Diffstat (limited to 'community/py3-distro')
-rw-r--r--community/py3-distro/APKBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/community/py3-distro/APKBUILD b/community/py3-distro/APKBUILD
new file mode 100644
index 0000000000..b80e7093f6
--- /dev/null
+++ b/community/py3-distro/APKBUILD
@@ -0,0 +1,33 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=py3-distro
+_pkgname=distro
+pkgver=1.4.0
+pkgrel=2
+pkgdesc="A Linux OS platform information API"
+options="!check" # Some tests fail
+url="https://github.com/nir0s/distro"
+arch="noarch"
+license="Apache-2.0"
+depends="python3"
+makedepends="py3-setuptools"
+checkdepends="py3-pytest py3-pytest-cov"
+source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+builddir="$srcdir"/$_pkgname-$pkgver
+
+replaces=py-distro # Backwards compatibility
+provides=py-distro=$pkgver-r$pkgrel # Backwards compatibility
+
+build() {
+ python3 setup.py build
+}
+
+check() {
+ python3 -m pytest
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="eac7d32ea77c2074e57c6828a8b2e4d4d01e9c46cb0f7adbd99998630b0af4924bf18d05d5f5b42fef5603b024ef835dbb4c05fc88310f5e64d193514b2fc10f distro-1.4.0.tar.gz"